HDU5182 PM2.5

Problem Description

Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of PM2.5 one city have, the better quality of air it have. So we sort the cities according to the content of PM2.5 in asending order.

Sometimes one city’s rank may raise, however the content of PM2.5 of this city may raise too. It means that the quality of this city is not promoted. So this way of sort is not rational. In order to make it reasonable, we come up with a new way to sort the cityes. We order this cities through the diffrence between twice measurement of content of PM2.5 (first measurement – second measurement) in descending order, if there are ties, order them by the second measurement in asending order , if also tie, order them according to the input order.

Input

Multi test cases (about 100), every case contains an integer n which represents there are n cities to be sorted in the first line.
Cities are numbered through 0 to n−1.
In the next n lines each line contains two integers which represent the first and second measurement of content of PM2.5
The ith line describes the information of city i−1
Please process to the end of file.

[Technical Specification]
all integers are in the range [1,100]

Output

For each case, output the cities’ id in one line according to their order.

Sample Input

2
100 1
1 2
3
100 50
3 4
1 2

Sample Output

0 1
0 2 1

思路

大水题

代码

#include <cstdio>
#include <algorithm>
using namespace std;
struct p {
    int num;
    int first;
    int second;
    int cha;
};
p s[110];
bool cmp(p a,p b)
{
    if(a.first-a.second != b.first-b.second) {
        return a.first-a.second > b.first-b.second;
    }
    if(a.second != b.second)
    return a.second < b.second;
    return a.num < b.num;
}
int main()
{
    int n;
    while(scanf("%d",&n) != EOF) {
        for(int i = 0 ; i < n ; i ++) {
            s[i].num = i;
            scanf("%d%d",&s[i].first,&s[i].second);
        }
        sort(s,s+n,cmp);
        for(int i = 0 ; i < n-1 ; i ++) printf("%d ",s[i].num);
        printf("%d\n",s[n-1].num);
    }
    return 0;
}
  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值