HDU5170PM2.5

PM2.5

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1056    Accepted Submission(s): 524


Problem Description
Nowadays we use content of PM2.5 to discribe the quality of air. The lower content of PM2.5 one city have, the better quality of air it have. So we sort the cities according to the content of PM2.5 in asending order.

Sometimes one city’s rank may raise, however the content of PM2.5 of this city may raise too. It means that the quality of this city is not promoted. So this way of sort is not rational. In order to make it reasonable, we come up with a new way to sort the cityes. We order this cities through the diffrence between twice measurement of content of PM2.5 (first measurement – second measurement) in descending order, if there are ties, order them by the second measurement in asending order , if also tie, order them according to the input order.
 

Input
Multi test cases (about  100 ), every case contains an integer  n  which represents there are  n  cities to be sorted in the first line.
Cities are numbered through 0 to  n1 .
In the next  n  lines each line contains two integers which represent the first and second measurement of content of PM2.5
The ith line describes the information of city  i1
Please process to the end of file.

[Technical Specification]
all integers are in the range  [1,100]
 

Output
For each case, output the cities’ id in one line according to their order.
 

Sample Input
  
  
2 100 1 1 2 3 100 50 3 4 1 2
 

Sample Output
  
  
0 1 0 2 1
 

看不懂题目意思的小伙伴可以去BEST CODE 里面看看中文版的http://bestcoder.hdu.edu.cn/contests/contest_chineseproblem.php?cid=570&pid=1001


这里其实根据题目意思可以直接将其概括为进行三次排序就行了,这里我用了sort 和qsort 两种方法,值得注意的时候qsort的返回值是有三种的-1,0,1,这时候我们就要考虑到使用qsort函数时候的不稳定性;
对于sort 和qsort函数不懂的小伙伴可以自己去搜一搜这两个函数的函数原型;

给出代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
struct P
{
	int a, b; //表示第一次和第二次的 PM值大小
	int dum;  //表示第一次减去第二次 的大小
	int num;  //表示他们的输入顺序;
}PM[10005];
/*
int Cmpq(const void *c, const void *d)
{
	struct P *aa = (P *)c;
	struct P *bb = (P *)d;
	if (aa->dum != bb->dum)return aa->dum < bb->dum?1:-1;//降序排序;
	else
	{
		if (aa->b != bb->b)return aa->b > bb->b ? 1 : -1;//升序排序;
		else return aa->num > bb->num ? 1 : -1;
	}//升序排序;
}
*/

bool Cmp(P f,P s)
{
	if (f.dum != s.dum)return f.dum > s.dum; //第一次 降序排序
	{
		if (f.b != s.b)return f.b < s.b;//第二次 升序排序
		else return f.num < s.num; //第三次  升序排序
	}
	
}

int main()
{
	int x,y;
	int n;
	while (cin >> n)
	{
		for (int i = 0; i < n; i++)
		{
			cin >>x>> y;
			PM[i].a = x; PM[i].b = y;
			PM[i].dum = x-y;
			PM[i].num = i;
		}
		sort(PM, PM + n, Cmp);
		//qsort(PM,n,sizeof(PM[1]), Cmpq);
		for (int i = 0; i < n; i++)
		{
			if (i == 0)
				cout << PM[i].num;
			else cout << " " << PM[i].num;
		}
		cout << endl;
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值