[编译原理]7-4 翻译布尔表达式-A

大家都学过了布尔表达式的翻译,其中有一个拉链-回填技术,这次我们就练习这个技术。

注意,在布尔表达式中,“并且”运算的优先级是要高于“或者”运算的。

输入格式:

输入为一行字符串,例如: a < b or c < d and e < f

每个符号都用空格间隔。

其中逻辑运算符包含 and 和 or , 关系运算符包含 < 、> 、<= 、 >= 、== 、 != 。

输出格式:

假链跳到0,真链跳到1,表达式序号从100开始排。

输入样例1:

a < b or c < d and e < f

输出样例1:

100(j<,a,b,1)
101(j,_,_,102)
102(j<,c,d,104)
103(j,_,_,0)
104(j<,e,f,100)
105(j,_,_,103)

输入样例2:

a < b and c > d or e > f

输出样例2:

100(j<,a,b,102)
101(j,_,_,104)
102(j>,c,d,1)
103(j,_,_,101)
104(j>,e,f,100)
105(j,_,_,0)
#include<bits/stdc++.h>
using namespace std;
vector <string> ans;
string s;
int main(){

        getline(cin,s);
        s+=" end";
        string x;
        int t =1,f=100;
        stringstream ss(s);
        int id =100;
        while(ss>>x){
            if(x == "or"||x=="end"){
                if(x=="or") f+=2;
                else f=0;
                int i;
                int n = ans.size();
                for(i=0;i<n-3;i+=3){
                printf("%d(j%s,%s,%s,%d)\n",id,ans[i+1].c_str(),ans[i+0].c_str(),ans[i+2].c_str(),id+2);
                id++;
                printf("%d(j,_,_,%d)\n",id,f);
                f =id++;
            }
                printf("%d(j%s,%s,%s,%d)\n",id,ans[i+1].c_str(),ans[i].c_str(),ans[i+2].c_str(),t);
                t = id -(n-3)/3*2;
                id++;
                printf("%d(j,_,_,%d)\n",id,f);
                id++;
                ans.clear();
                if(x=="end")break;
            }

            else if(x == "and") f+=2;
            else
                ans.push_back(x);
            }
    }
  • 2
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 3
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 3
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值