A hard puzzle
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 48051 Accepted Submission(s): 17637
Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
Output
For each test case, you should output the a^b's last digit number.
Sample Input
7 66
8 800
Sample Output
9
6
//a^b mod 10
#include<stdio.h>
using namespace std;
long long power(long long a,long long n,long long mod)
{
long long res=1;
while(n>0)
{
if(n&1)
res=res*a%mod;
a=a*a%mod;
n>>=1;
}
return res;
}
int main()
{
long long a,b;
while(~scanf("%lld%lld",&a,&b))
{
long long res=power(a,b,10);
printf("%lld\n",res);
}
return 0;
}