HDU 1068 Girls and Boys(最大独立集)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12791    Accepted Submission(s): 6066


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
 
 
7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0
Sample Output
 
 
5
2

就是找一个最大的集合,这个集合里的任意二个元素都没有题中的“romantically involved”关系,今天才知道最大独立集这个词微笑,二分图的最大独立集=总元素个数n-最大匹配数/2;

比较烦这种不明确说明数据范围的题~~~

下面是用普通数组做的,时间1500多ms,而用vector做的,才500多ms!!!!!!,普通的代码最下面

#include<stdio.h>
#include<string.h>
#include<vector>
using namespace std;
vector<int>v[505];
int use[505];
int link[505];
int n;
int dfs(int k)
{
	for(int i=0;i<v[k].size() ;i++)
	{
		if(!use[v[k][i]])
		{
			use[v[k][i]]=1;
			if(link[v[k][i]]==-1||dfs(link[v[k][i]]))
			{
				link[v[k][i]]=k;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		{
			int a,b;
			scanf("%d: (%d)",&a,&b);
			for(int j=0;j<b;j++)
			{
				int c;
				scanf("%d",&c);
				v[a].push_back(c); 
			}
		}
		int sum=0;
		memset(link,-1,sizeof(link));
		for(int i=0;i<n;i++)
		{
			memset(use,0,sizeof(use));
			if(dfs(i)) sum++;
		}
		printf("%d\n",n-sum/2);
		for(int i=0;i<n;i++)//谨记!每次清除vector 
		{
			v[i].clear() ;
		}
	}
	return 0;
}

普通:

#include<stdio.h>
#include<string.h>
using namespace std;
int mat[505][505];
int use[505];
int link[505];
int n;
int dfs(int k)
{
	for(int i=0;i<n;i++)
	{
		if(mat[k][i]==1&&!use[i])
		{
			use[i]=1;
			if(link[i]==-1||dfs(link[i]))
			{
				link[i]=k;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	while(~scanf("%d",&n))
	{
		memset(mat,0,sizeof(mat));
		for(int i=0;i<n;i++)
		{
			int a,b;
			scanf("%d: (%d)",&a,&b);
			for(int j=0;j<b;j++)
			{
				int c;
				scanf("%d",&c);
				mat[a][c]=1;
			}
		}
		int sum=0;
		memset(link,-1,sizeof(link));
		for(int i=0;i<n;i++)
		{
			memset(use,0,sizeof(use));
			if(dfs(i)) sum++;
		}
		printf("%d\n",n-sum/2);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值