nyoj 1278 Prototypes analyze(判二叉树形态)

Prototypes analyze

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述

ALpha Ceiling Manufacturers (ACM) is analyzing the properties of its new series of Incredibly Collapse-Proof Ceilings (ICPCs).  An ICPC consists of n layers of material, each with a different value of collapse resistance (measured as a positive integer). The analysis ACM wants to run will take the collapse-resistance values of the layers, store them in a binary search tree, and check whether the shape of this tree in any way correlates with the quality of the whole construction. Because, well, why should it not?  To be precise, ACM takes the collapse-resistance values for the layers, ordered from the top layer to the bottom layer,  and inserts them one-by-one into a tree. The rules for inserting a value v are:

• If the tree is empty, make v the root of the tree.

 If the tree is not empty, compare v with the root of the tree.

 If v is smaller, insert v into the left subtree of the root,

 otherwise insert v into the right subtree.

 

ACM has a set of ceiling prototypes it wants to analyze by trying to collapse them. It wants to take each group of ceiling prototypes that have trees of the same shape and analyze them together. For example , assume ACM is considering five ceiling prototypes with three layers each, as described by Sample Input 1 and shown in Figure C.1. Notice that the first prototype’s top layer has collapseresistance value 2, the middle layer has value 7, and the bottom layer has value 1. The second prototype has layers with collapse-resistance values of 3, 1, and 4 – and yet these two prototypes induce the same tree shape, so ACM will analyze them together. Given a set of prototypes, your task is to determine how many different tree shapes they induce.

 

输入
The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8).
Each test case specifies :
● Line 1: two integers n (1 ≤ n ≤ 50), which is the number of ceiling prototypes to analyze,
and k (1 ≤ k ≤ 20), which is the number of layers in each of the prototypes.
● The next n lines describe the ceiling prototypes. Each of these lines contains k distinct
integers ( between 1 and 1e6, inclusive ) , which are the collapse-resistance values of the
layers in a ceiling prototype, ordered from top to bottom.
输出
For each test case generate a single line containing a single integer that is the number of different tree
shapes.
样例输入
1
5 3
2 7 1
1 5 9
3 1 4
2 6 5
9 7 3
样例输出
4
题意:给你n个树,按二叉搜索树建树,完了问不同形态的树有多少个。
 #include<stdio.h>
#include<stdlib.h>
#include<string.h>
using namespace std;
struct tree{
	int val;
	tree *left,*right;
	tree(int e):val(e),left(NULL),right(NULL){}
}*Tree[55];
int vis[55];
tree* buliTree(tree *root,int k)
{//建树 
	if(root==NULL)
	{
		return new tree(k);
	}
	if(k>root->val) root->right=buliTree(root->right,k);
	else root->left=buliTree(root->left,k);
	return root;
}
int find(tree *r1,tree *r2)
{//判断两颗树是否相同,这里只判了形态,不判节点值 
	if(!r1&&!r2)
		return 1;//是 
	else if(r1!=NULL&&r2!=NULL)
		return find(r1->left,r2->left)&&find(r1->right,r2->right);
	return 0;//否 
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n,k,a;
		for(int i=0;i<55;i++)
		{//每次初始化 
			Tree[i]=NULL;
		}
		memset(vis,0,sizeof(vis));
		scanf("%d%d",&n,&k);
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<k;j++)
			{
				scanf("%d",&a);
				Tree[i]=buliTree(Tree[i],a);
			}
		}
		int sum=0;//计数 
		for(int i=0;i<n;i++)
		{
			if(!vis[i])
			{
				vis[i]=1;
				sum++;
				for(int j=i+1;j<n;j++)
				{
					if(find(Tree[i],Tree[j]))
					{
						vis[j]=1;
					}
				}
			}	
		}
		printf("%d\n",sum);
	}
	return 0;
}        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值