动态规划 002:Zipper

002:Zipper

总时间限制: 1000ms 内存限制: 65536kB
描述
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming “tcraete” from “cat” and “tree”:

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming “catrtee” from “cat” and “tree”:

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form “cttaree” from “cat” and “tree”.
输入
The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
输出
For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
样例输入

3
cat tree tcraete
cat tree catrtee
cat tree cttaree

样例输出

Data set 1: yes
Data set 2: yes
Data set 3: no

简而言之:
判断输入每一行的第一个string和第二个string能否组成第三个string
且不改变自己字母的先后顺序

解题思路:
简化问题:判断a[i]与b[j]能否组成c[i+j+1]
MaxLen[i][j]表示a的前i个字母(a[i-1])与b的前j个字母能否组成c[i+j+1]
初始化问题: MaxLen[0][0]=1; 空字符由空字符组成
if(MaxLen[i][j]==1 && c[i+j]==a[i]) MaxLen[i+1][j]=1;
if(MaxLen[i][j]==1 && c[i+j]==b[j]) Maxlen[i][j+1]=1;

#include<iostream>
#include<cstring>
#include<memory.h>
using namespace std;

char a[202];
char b[202];
char c[404];
bool ok[202][202]={0};
int main(){
	int n;
	cin>>n;
	for (int t=0; t<n;t++){
		cin>>a>>b>>c;
	bool ok[202][202]={0};
	int length1=strlen(a);
	int length2=strlen(b);
	int length3=strlen(c);
	ok[0][0]=1;
	for (int i=0; i<=length1;i++){
	for (int j=0;j<=length2;j++){
			if(ok[i][j]==1 && a[i]==c[i+j])
					ok[i+1][j]=1;
			if(ok[i][j]==1 && b[j]==c[i+j])
					ok[i][j+1]=1;
		}
	}
	if (ok[length1][length2]==1)
				cout<<"Data set "<<t+1<<": "<<"yes"<<endl;
		else cout<<"Data set "<<t+1<<": "<<"no"<<endl;
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值