C 完全二叉树和二叉搜索树 列表表示树 04-树6 Complete Binary Search Tree (30分)

04-树6 Complete Binary Search Tree (30分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

解题
层序遍历——用链表表示需要队列进出;
而用数组表示则按顺序和输出即可;
且完全二叉树用数组保存不会空间浪费;
故本体选用数组保存树节点;
下标为 i 的左子树下标为 (i+1)*2 -1,右子树下标为 (i+1)*2;
注意点
n个数字的完全二叉树层数为h=log2(n+1),不算最底下未填满那层;
最后一行剩余的个数X=n-(pow(2,前面的行数)-1)
若最后一行个数小于最后一行能放个个数的一半——X<=pow(2,h)/2
根节点左边的数有pow(2,h-1)-1+X个,即根节点的下标;
若最后一行左半边放满,——X>pow(2,h)/2
根节点左边的数有pow(2,h-1)-1+pow(2,h)/2

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;

//列表存储树
int result[1010];
int IN[1010]; 
//根i  左子树2i+1 右 2i+2 

void solve(int abegin, int n, int root) {
	if (!n) return;
	int leftn; 
	double x, h;
	//最后一层(设高度h+1)的节点数0<=x<2^h
	h = floor(log(n + 1.0) / log(2));//floor(n)返回<=n的最大整数
	x = n - (pow(2, h) - 1);
	leftn =(int) (x < pow(2, h - 1)) ? 
		pow(2, h - 1) - 1 + x : pow(2, h - 1) - 1 + pow(2, h - 1);

	result[root] = IN[abegin + leftn];
	solve(abegin, leftn, root * 2 + 1);
	solve(abegin + leftn + 1, n - 1 - leftn, (root + 1) * 2);
}
int n;  
int main()
{
	cin>>n;
	for(int i=0;i<n;i++){
		cin>>IN[i];       
	}
	sort(IN,IN+n);
	solve(0,n,0);
	for(int i=0;i<n-1;i++)
	cout<<result[i]<<" ";
    cout<<result[n-1];
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值