MPI Maelstrom(dijkstra算法)c语言

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.'' 

Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on. 

Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.
Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35

本题是一个典型的最短路问题,题目给出的是各个点关系的矩阵,因为到本身为零,且 是无向图,所以给出了一半的矩阵。

#include<stdio.h> 
#include <string.h> 
#include<algorithm>
#define INF 9999999 
int map[110][110],n;
void dijkstra()
{
	int i,j,ans=-1,min,v;
	//dijkstra算法核心 
	int dis[110],book[110];
	for(i=1;i<=n;i++)//找出从原点到各个点之间的距离 
	{
		dis[i]=map[1][i];
		book[i]=0;
	}	
	book[1]=1; 
	for(i=1;i<=n;i++)
	{
		min=INF;
		for(j=1;j<=n;j++)
		{	
			if(book[j]==0 && dis[j]<min)//找出未标记的且原点到该点的最小距离 
			{
				min=dis[j];
				v=j;
			}
		}
		book[v]=1;//标记该点  
		for(j=1;j<=n;j++)	
			if(book[j]==0 && dis[v]+map[v][j]<dis[j])//找出更小的距离并更新dis数组 
				dis[j]=dis[v]+map[v][j];
	}
	for(i=2;i<=n;i++)
		if(dis[i]>ans)//用时最长的那个点就是传递完信息所用的时间 
		 ans=dis[i];
	printf("%d\n",ans);
}
int main()
{
	char s[10];
	int i,j;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)//初始化map矩阵 
			for(j=1;j<=n;j++)
				if(i==j)
					map[i][j]=0;
				else
					map[i][j]=INF;
		for(i=2;i<=n;i++)//因为可能有 X 所以要以字符串的形式输入每一个值 
			for(j=1;j<i;j++)
			{
				scanf("%s",s);
				if(s[0]!='x')
					map[i][j]=map[j][i]=atoi(s);//C++头文件,将字符串转化为整数 
			}
		dijkstra();
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值