Light Bulb(三分/推公式)

Description

Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers Hh and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000

题目大意:T组数据,每组给出灯离地面高度H,人的身高h,灯距墙的距离D,人站在不同位置影子的长度不同,求最长的影子长度,也是分三种情况讨论。

题解:设人距灯的距离为x,从灯正下方走到影子正好到墙角,影子的长度不断增加,此时由相似三角形得影子长度为D-h*D/H;

中途,墙上出现影子,同样用相似三角形推出墙上影长为h-(H-h)*(D-x)/x,化简得H-(H-h)*D/x,此时影长为H-(H-h)*D/x-D-x;

最后,人走到最右,影子全在墙上,影长为D。

即(1)影长=h*D/H;

(2)影长=D-x+H-(H-h)*D/x;

(3)影长=D;

可由(2)的不等式定理得x=(H-h)*D/x时,影长取最大值,即D+H-2*sqrt((H-h)*D),前提是x小于D且大于D-h*D/H(初始和结尾影长),如果x小于D-h*D/H,那最长就是h*D/H,否则为h。

公式法代码:
#include<stdio.h>
#include<math.h>
#include<stdlib.h>
int main()
{
	int t;
        double H,h,D,k;
	scanf("%d",&t);
	while (t--)
	{
		scanf("%lf%lf%lf",&H,&h,&D);
		k=D-h*D/H;
		if ( k<=sqrt((H-h)*D)&&D>=sqrt((H-h)*D) )
                      k=D+H-2*sqrt((H-h)*D);
		else if (sqrt((H-h)*D)<k)
                      k=h*D/H;
                else
                      k=h;
		printf("%.3lf\n",k);
	}
	return 0;
}
三分法代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;const double eps=1e-9;
double D,H,h;
double calc(double x)
{
    return D-x+H-(H-h)*D/x;
}

double solve(double l,double r)
{
    double mid,midmid;
    double d1,d2;
    do
    {
        mid=(l+r)/2;
        midmid=(mid+r)/2;
        d1=calc(mid);
        d2=calc(midmid);
        if(d1>=d2)             
             r=midmid;
        else 
             l=mid;
    }
    while(r-l>=eps);
          return d1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        printf("%.3lf\n",solve((H-h)*D/H,D));
    }
    return 0;
}

萌新代码,请多多关照,如有不足,多多见谅^_^

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值