Longge's problem

Description

Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1 < N < 2^31),you are to calculate ∑gcd(i, N) 1<=i <=N. 

"Oh, I know, I know!" Longge shouts! But do you know? Please solve it. 

Input

Input contain several test case. 
A number N per line. 

Output

For each N, output ,∑gcd(i, N) 1<=i <=N, a line

Sample Input

2
6

Sample Output

3
15

题解:选择欧拉函数模板时要注意,之前那种会T,eular(n/i)代表小于等于n与n最大公约数为i的值的个数,再*i就为gcd的和。而n/i*eular(i)求得是最大公约数为n/i的值的gcd的和。

代码如下:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<stack>
#include<vector>
#include<queue>
#include<set>
#include<algorithm>
#define max(a,b)   (a>b?a:b)
#define min(a,b)   (a<b?a:b)
#define swap(a,b)  (a=a+b,b=a-b,a=a-b)
#define X (sqrt(5)+1)/2.0
#define maxn 320007
#define N 100000000
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define read(x) scanf("%d",&x)
#define put(x) printf("%d\n",x)
#define memset(x,y) memset(x,y,sizeof(x))
#define Debug(x) cout<<x<<" "<<endl
#define lson i << 1,l,m
#define rson i << 1 | 1,m + 1,r
#define mod 1000000009
#define e  2.718281828459045
#define eps 1.0e18
#define ll long long
using namespace std;

int eular(ll n)
{
    ll ret=n;
    for (ll i=2;i*i<=n;i++)
        if (n%i==0)
        {
            ret=ret-ret/i;
            while (n%i==0)
                n/=i;
        }
    if(n>1)
        ret=ret-ret/n;
    return ret;
}

int main()
{
    ll n;
    while(cin>>n)
    {
        ll sum=0;
        for(ll i=1;i<=sqrt(n);i++)
        {
            if(n%i==0)
            {
                sum+=i*eular(n/i);
                if(i*i!=n)
                    sum+=n/i*eular(i);
            }
        }
        cout<<sum<<endl;;
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值