El Dorado 2010.3.6

El Dorado 2010.3.6

DP:求一个序列中长度为k的上升序列有多少个。

注意,枚举长度的时候要放在最外层循环。

 

El Dorado

 

Time Limit:1000MS  Memory Limit:65536K

Total Submit:29 Accepted:9

 

Description

 

Bruce Force has gone to Las Vegas, the El Doradofor gamblers. He is interested especially in one betting game, where a machineforms a sequence of n numbers by drawing random numbers. Each player shouldestimate beforehand, how many increasing subsequences of length k will exist inthe sequence of numbers.

A subsequence of a sequence a1, ..., an isdefined as ai1, ..., ail, where 1 ≤ i1 < i2 < ...< il ≤ n. The subsequence is increasing, if aij-1 < aij for all 1 <j ≤ l.

Bruce doesn't trust the Casino to count thenumber of increasing subsequences of length k correctly. He has asked you ifyou can solve this problem for him.

 

 

Input

 

The input contains several test cases. Thefirst line of each test case contains two numbers n and k (1 ≤ k ≤ n ≤ 100), wheren is the length of the sequence drawn by the machine, and k is the desiredlength of the increasing subsequences. The following line contains n pairwisedistinct integers ai (-10000 ≤ ai ≤ 10000 ), where ai is the ith number in the sequence drawn by themachine.

The last test case is followed by a linecontaining two zeros.

 

 

Output

 

For each test case, print one line with thenumber of increasing subsequences of length k that the input sequence contains.You may assume that the inputs are chosen in such a way that this number fitsinto a 64 bit signed integer (in C/C++, you may use the data type "longlong", in Java the data type "long").

 

Sample Input

 

 

10 5

1 2 3 4 5 6 7 8 9 10

3 2

3 2 1

0 0

 

 

Sample Output

 

 

252

0

 

 

Source

 

ULM 2008

#include <cstdio>
#include <cstring>

#define MAXN 100+10

__int64 f[MAXN][MAXN];
__int64 num[MAXN];
int n,k,i,j,p;
__int64 goal;

int main()
{
	while (scanf("%d %d",&n,&k),n)
	{
		memset(f,0,sizeof(f));
		memset(num,0,sizeof(num));
		goal=0;
		for(i=1;i<=n;i++)
			scanf("%I64d",&num[i]);
        for(i=1;i<=n;i++)
			f[i][1]=1;
		for(j=2;j<=k;j++)
			for(i=1;i<=n;i++)
				for(p=1;p<i;p++)
					if(num[p]<num[i])
						f[i][j]+=f[p][j-1];
        for(i=1;i<=n;i++)
			goal+=f[i][k];
		printf("%I64d\n",goal);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
自动控制节水灌溉技术的高低代表着农业现代化的发展状况,灌溉系统自动化水平较低是制约我国高效农业发展的主要原因。本文就此问题研究了单片机控制的滴灌节水灌溉系统,该系统可对不同土壤的湿度进行监控,并按照作物对土壤湿度的要求进行适时、适量灌水,其核心是单片机和PC机构成的控制部分,主要对土壤湿度与灌水量之间的关系、灌溉控制技术及设备系统的硬件、软件编程各个部分进行了深入的研究。 单片机控制部分采用上下位机的形式。下位机硬件部分选用AT89C51单片机为核心,主要由土壤湿度传感器,信号处理电路,显示电路,输出控制电路,故障报警电路等组成,软件选用汇编语言编程。上位机选用586型以上PC机,通过MAX232芯片实现同下位机的电平转换功能,上下位机之间通过串行通信方式进行数据的双向传输,软件选用VB高级编程语言以建立友好的人机界面。系统主要具有以下功能:可在PC机提供的人机对话界面上设置作物要求的土壤湿度相关参数;单片机可将土壤湿度传感器检测到的土壤湿度模拟量转换成数字量,显示于LED显示器上,同时单片机可采用串行通信方式将此湿度值传输到PC机上;PC机通过其内设程序计算出所需的灌水量和灌水时间,且显示于界面上,并将有关的灌水信息反馈给单片机,若需灌水,则单片机系统启动鸣音报警,发出灌水信号,并经放大驱动设备,开启电磁阀进行倒计时定时灌水,若不需灌水,即PC机上显示的灌水量和灌水时间均为0,系统不进行灌水。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值