HDU 1102 Constructing Roads【最小生成树】

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum. 

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built. 

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source


Prime  算法

/*
    HDU 1102 Constructing Roads
    题意:给定n个村庄的道路情况,在q个道路已经建成的情况下求最小生成树
    类型:最小生成树
    分析:把建好的道路费用改为0,跑一遍最小生成树就行.写这道题是想复习一下图论,嗯,就酱紫..
*/
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 0x7fffffff;
const int maxn = 105;
int lowcost[maxn],vis[maxn],Map[maxn][maxn];
int n;
int prime(){
    int next;
    int Min,mincost=0;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
        lowcost[i]=Map[1][i];
    vis[1]=1;
    for(int i=1;i<n;i++){
        Min=INF;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&Min>lowcost[j]){
                Min=lowcost[j];next=j;
            }
        }
        mincost+=Min;
        vis[next]=1;
        for(int j=1;j<=n;j++){
            if(!vis[j]&&lowcost[j]>Map[next][j]){
                lowcost[j]=Map[next][j];
            }
        }
    }
    return mincost;
}
int main()
{
    int q,x,y;
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<=n;i++)
            for(int j=0;j<=n;j++)
                Map[i][j]=INF;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                scanf("%d",&Map[i][j]);
            }
        }
        cin>>q;
        while(q--){
            scanf("%d%d",&x,&y);
            Map[x][y]=Map[y][x]=0;
        }
        printf("%d\n",prime());
    }
    return 0;
}

Kruskal 算法:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 0x7fffffff;
const int maxm = 10005;
int fa[maxm];
struct Edge{
    int dis,u,v;
    Edge(int u,int v,int dis):u(u),v(v),dis(dis){}
    Edge(){}
}edge[maxm];
bool cmp(Edge a,Edge b){
    return a.dis<b.dis;
}
int Find(int x){
    return x==fa[x]?x:x=Find(fa[x]);
}
void unit(int x,int y){
    x=Find(x);y=Find(y);
    if(x!=y)fa[x]=y;
}
int main()
{
    int n,q,res;
    int x,y,cnt,d;
    while(scanf("%d",&n)!=EOF){
        cnt=0,res=0;
        for(int i=1;i<=n;i++){
            fa[i]=i;
            for(int j=1;j<=n;j++){
                scanf("%d",&d);
                if(j>i){
                    edge[cnt++]=Edge(i,j,d);
                }
            }
        }
        sort(edge,edge+cnt,cmp);
        cin>>q;
        while(q--){
            scanf("%d%d",&x,&y);
            unit(x,y);
        }
        for(int i=0;i<cnt;i++){
            if(Find(edge[i].u)!=Find(edge[i].v)){
                unit(edge[i].u,edge[i].v);
                res+=edge[i].dis;
            }
        }
        printf("%d\n",res);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值