【HDU】-5100-Chessboard(思维)

Chessboard

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1088    Accepted Submission(s): 464


Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.
 

Input
There are multiple test cases in the input file.
First line contain the number of cases T ( T10000 ). 
In the next T lines contain T cases , Each case has two integers n and k. ( 1n,k100 )
 

Output
Print the maximum number of chessboard squares tiled.
 

Sample Input
  
  
2 6 3 5 3
 

Sample Output
  
  
36 24

注意一点:1*k的骨牌不是1*k的长方形。

不能重叠,每次用1*k的骨牌。

#include<cstdio> 
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define CLR(a,b) memset(a,b,sizeof(a))
int a[1010][1010];
int row[1010],rad[1010],cul[1010],cad[1010];
int main()
{
	int u,n,k;
	scanf("%d",&u);
	while(u--)
	{
		int ans;
		scanf("%d%d",&n,&k);
		if(n<k)
			ans=0;
		else
		{
			int minn=min(n%k,k-n%k);
			ans=n*n-minn*minn;
		}
		printf("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值