思维 hdu 5100 (chessboard)

chessboard

Problem Description
Consider the problem of tiling an n×n chessboard by polyomino pieces that are k×1 in size; Every one of the k pieces of each polyomino tile must align exactly with one of the chessboard squares. Your task is to figure out the maximum number of chessboard squares tiled.

Input
There are multiple test cases in the input file.
First line contain the number of cases T (T≤10000). 
In the next T lines contain T cases , Each case has two integers n and k. (1≤n,k≤100)
 
Output
Print the maximum number of chessboard squares tiled.
 
Sample Input
2
6 3
5 3
 
Sample Output
36
24
题意:给出n*n的矩阵,问用k*1的矩形覆盖,最多能覆盖多少小矩形。

题解:规律是:分成三种情况,n<k,肯定不能覆盖。n>k时,设m=n%k,如果m<=k/2,不能覆盖的矩形为m*m,相反,不能覆盖为(k-m)*(k-m).详细题解

 

<span style="font-size:18px;">#include<cstdio>
#include<cstring>
using namespace std;

void solve(int n,int k){
	int s=n*n;
	if (n<k)
	printf ("0\n");
	else{
		int a=n%k;
		if (a<=k/2)
		printf ("%d\n",s-a*a);
		else{
			printf ("%d\n",s-(k-a)*(k-a));
		}
		
	}
}

int main(){
	int t,n,k;
	scanf ("%d",&t);
	while (t--){
		scanf ("%d %d",&n,&k);
		solve(n,k);	
	}
	return 0;
} </span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值