002:Charm Bracelet

描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23

大意

有n种物品,第 i 种物品的价值是 v[i],重量是 w[i],给定容量为 m 的背包,问背包能装下的最大价值是多少,0-1背包问题。

AC Code

#include<iostream>
#include<cmath>
#include<stack>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
typedef long long ll;
const double PI=acos(-1);
const double EPS=1e-6;
const int MAXN=13000+10;
int w[MAXN],d[MAXN];
int dp[MAXN];
using namespace std;

int main(){

    //freopen("C:\\Users\\Ambition\\Desktop\\in.txt","r",stdin);
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=1; i<=n; i++){
		scanf("%d%d",&w[i],&d[i]);
	}
	memset(dp,0,sizeof(dp));
	for(int i=1; i<=n; i++){
		for(int j=m; j>=w[i]; j--){
			dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
		}
	}
	printf("%d\n",dp[m]);
	return 0;
}

写这道题的时候踩了一些坑,最开始的时候我是用二维数组递推的,交上去超内存,然后看了老师的思路,采用一维滚动数组。但是交上去莫名其妙又RE了,后来检查才知道是数组开小了。最后看见AC的时候,心里是很高兴的,这种心满意足感觉就像春风拂面,说不出的畅快。此中有真意,欲辩已忘言。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值