OpenJudge 016:Charm Bracelet

016:Charm Bracelet

总时间限制: 1000ms 内存限制: 65536kB

描述
Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a ‘desirability’ factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入

Line 1: Two space-separated integers: N and M
Lines 2…N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23

思想:
本题可以这样设dp[i][j]表示在前i个中选择总重量不超过j的物品的最大总魅力值,状态转移方程为dp[i][j]=dp[i-1]j,否则为dp[i][j]=dp[i-1][j-w[i]]+w[i]
但是可以看出,都是dp[i][j]都是与i-1行的元素有关,且在其前或其下,则可以用滚动一维数组逆序求得:dp[i]=max(dp[i-w[j]]+w[j],dp[i]),而另一种情况就是等于自身。可以看到边界条件是在前1个物品中选,若w<m,则dp[i]为w[1],否则为0。

代码:

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>

using namespace std;

struct Jew {
	int w;
	int d;
};

int dp[13000] = { 0 };

int main() {
	//freopen("in.txt", "r", stdin);
	int N, M;
	cin >> N >> M;
	Jew* jew = new Jew[N + 1];
	for (int i = 1; i <= N; ++i)
		cin >> jew[i].w >> jew[i].d;

	for (int i = 1; i <= M; ++i)//边界条件
		dp[i] = (jew[1].w <= i) ? jew[1].d : 0;

	for (int i = 2; i <= N; ++i)
		for (int j = M; j >= 1; --j)
			if (j >= jew[i].w)
				dp[j] = max(dp[j - jew[i].w] + jew[i].d, dp[j]);

	cout << dp[M] << endl;

	delete[]jew;
	return 0;
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值