HDU 2642 Stars (二维树状数组)

Stars

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/65536 K (Java/Others)
Total Submission(s): 711    Accepted Submission(s): 309


Problem Description
Yifenfei is a romantic guy and he likes to count the stars in the sky.
To make the problem easier,we considerate the sky is a two-dimension plane.Sometimes the star will be bright and sometimes the star will be dim.At first,there is no bright star in the sky,then some information will be given as "B x y" where 'B' represent bright and x represent the X coordinate and y represent the Y coordinate means the star at (x,y) is bright,And the 'D' in "D x y" mean the star at(x,y) is dim.When get a query as "Q X1 X2 Y1 Y2",you should tell Yifenfei how many bright stars there are in the region correspond X1,X2,Y1,Y2.

There is only one case.
 

Input
The first line contain a M(M <= 100000), then M line followed.
each line start with a operational character.
if the character is B or D,then two integer X,Y (0 <=X,Y<= 1000)followed.
if the character is Q then four integer X1,X2,Y1,Y2(0 <=X1,X2,Y1,Y2<= 1000) followed.
 

Output
For each query,output the number of bright stars in one line.
 

Sample Input
  
  
5 B 581 145 B 581 145 Q 0 600 0 200 D 581 145 Q 0 600 0 200
 

Sample Output
  
  
1 0
 

Author
teddy
 

Source
 

Recommend
teddy
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn=1005;
int c[maxn][maxn];
bool f[maxn][maxn];
inline int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int y,int val)
{
    int yt;
    f[x][y]=(val==1?1:0);
    while(x<=maxn)
    {
        yt=y;
        while(yt<=maxn)
        {
            c[x][yt]+=val;
            yt+=lowbit(yt);
        }
        x+=lowbit(x);
    }
}
int sum(int x,int y)
{
    int s=0,yt;
    while(x>0)
    {
        yt=y;
        while(yt>0)
        {
            s+=c[x][yt];
            yt-=lowbit(yt);
        }
        x-=lowbit(x);
    }
    return s;
}
int main()
{
    int m,a,b,d,e;
    char op[2];
    while(~scanf("%d",&m))
    {
        memset(c,0,sizeof(c));
        memset(f,0,sizeof(f));
        while(m--)
        {
            scanf("%s%d%d",op,&a,&b);
            a++,b++;
            if(op[0]=='B')
            {
                if(f[a][b])continue;
                update(a,b,1);
            }
            else if(op[0]=='D')
            {
                if(!f[a][b])continue;
                update(a,b,-1);
            }
            else
            {
                scanf("%d%d",&e,&d);
                e++,d++;
                int ix=min(a,b),ax=max(a,b),iy=min(e,d),ay=max(e,d);
                printf("%d\n",sum(ax,ay)+sum(ix-1,iy-1)-sum(ix-1,ay)-sum(ax,iy-1));
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值