HDU-6308 Time Zone

HDU-6308 Time Zone

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of “UTC+X”, “UTC-X”, “UTC+X.Y”, or “UTC-X.Y” (0≤X,X.Y≤14,0≤Y≤9).

Output

For each test, output the time in the format of hh:mm (24-hour clock).

Sample Input
3
11 11 UTC+8
11 12 UTC+9
11 23 UTC+0
Sample Output
11:11
12:12
03:23


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=6308

分析

题意:根据北京时间(UTC +8),大于8的增加时间,小于8的减少时间。

思路:模拟题,只要将时间改变的过程实现出来就行了,不过有一点比较坑,如果不注意精度问题,就会出错。这一题主要考察的就是对精度的控制,如果你懒省事,估计就会时间超限(我就是这样),控制时间精度的方法就是在计算的时候加上0.1,时间超限的同学,检查一下你定义的数据类型是不是全是double

代码
#include <iostream>
#include <stdio.h>
#include <math.h>
using namespace std;
int main()
{
    int n;
    scanf("%d",&n);
    int a,b;
    double c;
    double num,Min;
    int carry1,carry2;
    for (int i=0;i<n;i++)
    {
        scanf("%d %d UTC%lf",&a,&b,&c);
        num=c-8;
        Min=60*(num-int(num))+0.1;
        carry1=0; // 时间减少时,标记分钟数是否够用
        if (b<fabs(Min)&&Min<0)
        {
            carry1=60;
            a-=1;
        }
        b=b+carry1+Min;
        carry2=0; // 时间增加时,标记分钟数是否大于等于60
        if (b>=60)
        {
            b=b-60;
            carry2=1;
        }
        a+=int(num)+carry2;
        if (a<0)
            a=24+a;
        if (a>=24)
            a-=24;
        printf("%02d:%02d\n",a,b);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值