8 Queens Chess Problem

  8 Queens Chess Problem 

In chess it is possible to place eight queens on the board so that no one queen can be taken by any other. Write a program that will determine all such possible arrangements for eight queens given the initial position of one of the queens.

Do not attempt to write a program which evaluates every possible 8 configuration of 8 queens placed on the board. This would require 88evaluations and would bring the system to its knees. There will be a reasonable run time constraint placed on your program.

Input 

The first line of the input contains the number of datasets, and it's followed by a blank line. Each dataset will be two numbers separated by a blank. The numbers represent the square on which one of the eight queens must be positioned. A valid square will be represented; it will not be necessary to validate the input.

To standardize our notation, assume that the upper left-most corner of the board is position (1,1). Rows run horizontally and the top row is row 1. Columns are vertical and column 1 is the left-most column. Any reference to a square is by row then column; thus square (4,6) means row 4, column 6.

Each dataset is separated by a blank line.

Output 

Output for each dataset will consist of a one-line-per-solution representation.

Each solution will be sequentially numbered $1 \dots N$. Each solution will consist of 8 numbers. Each of the 8 numbers will be the ROW coordinate for that solution. The column coordinate will be indicated by the order in which the 8 numbers are printed. That is, the first number represents the ROW in which the queen is positioned in column 1; the second number represents the ROW in which the queen is positioned in column 2, and so on.

The sample input below produces 4 solutions. The full 8$\times$8 representation of each solution is shown below.

DO NOT SUBMIT THE BOARD MATRICES AS PART OF YOUR SOLUTION!

   SOLUTION 1           SOLUTION 2           SOLUTION 3           SOLUTION 4

1 0 0 0 0 0 0 0      1 0 0 0 0 0 0 0      1 0 0 0 0 0 0 0      1 0 0 0 0 0 0 0
0 0 0 0 0 0 1 0      0 0 0 0 0 0 1 0      0 0 0 0 0 1 0 0      0 0 0 0 1 0 0 0
0 0 0 0 1 0 0 0      0 0 0 1 0 0 0 0      0 0 0 0 0 0 0 1      0 0 0 0 0 0 0 1
0 0 0 0 0 0 0 1      0 0 0 0 0 1 0 0      0 0 1 0 0 0 0 0      0 0 0 0 0 1 0 0
0 1 0 0 0 0 0 0      0 0 0 0 0 0 0 1      0 0 0 0 0 0 1 0      0 0 1 0 0 0 0 0
0 0 0 1 0 0 0 0      0 1 0 0 0 0 0 0      0 0 0 1 0 0 0 0      0 0 0 0 0 0 1 0
0 0 0 0 0 1 0 0      0 0 0 0 1 0 0 0      0 1 0 0 0 0 0 0      0 1 0 0 0 0 0 0
0 0 1 0 0 0 0 0      0 0 1 0 0 0 0 0      0 0 0 0 1 0 0 0      0 0 0 1 0 0 0 0

Submit only the one-line, 8 digit representation of each solution as described earlier. Solution #1 below indicates that there is a queen at Row 1, Column 1; Row 5, Column 2; Row 8, Column 3; Row 6, Column 4; Row 3,Column 5; ... Row 4, Column 8.

Include the two lines of column headings as shown below in the sample output and print the solutions in lexicographical order.

Print a blank line between datasets.

Sample Input 

1

1 1

Sample Output 

SOLN       COLUMN
 #      1 2 3 4 5 6 7 8

 1      1 5 8 6 3 7 2 4
 2      1 6 8 3 7 4 2 5
 3      1 7 4 6 8 2 5 3
 4      1 7 5 8 2 4 6 3


#include<iostream>
#include<cstdio>
using namespace std;


int n;
void backtracking( int, int*, int*, int*, int*, int* );
int main()
{
    int N;
    int row, col, array[8];
    bool blank_line;
    while( scanf( "%d", &N ) != EOF )
    {
        blank_line = 0;
        for( int i = 0 ; i < N ; i++ )
        {
            scanf( "%d%d", &row, &col );
            row--, col--;
            if( blank_line ) printf( "\n" );
            printf( "SOLN       COLUMN\n" );
            printf( " #      1 2 3 4 5 6 7 8\n" );
            printf( "\n" );
            blank_line = 1;
            int rowput[8] = {0}, colput[8] = {0}, leftslash[15] = {0}, rightslash[15] = {0};
            rowput[row] = 1;
            colput[col] = 1;
            leftslash[row+col] = 1;
            rightslash[row-col+7] = 1;
            n = 0;
            array[col] = row;
            backtracking( 0, array, rowput, colput, leftslash, rightslash );
        }
    }
    return 0;
}


void backtracking( int i, int array[], int rowput[], int colput[], int leftslash[] , int rightslash[] )
{
    if( i == 8 )
    {
        printf( "%2d      ", ++n );
        for( int j = 0 ; j < 8 ; j++ )
        {
            if( j ) printf( " " );
            printf( "%d", array[j]+1 );
        }
        printf( "\n" );
        return;
    }
    if( colput[i] )
    {
        backtracking( i+1, array, rowput, colput, leftslash, rightslash );
        return;
    }
    for( int j = 0 ; j < 8 ; j++ )
    {
        if( rowput[j] || leftslash[j+i] || rightslash[j-i+7] )
            continue;
        rowput[j] = 1;
        leftslash[i+j] = 1;
        rightslash[j-i+7] = 1;
        array[i] = j;
        backtracking( i+1, array, rowput, colput, leftslash, rightslash );
        rowput[j] = 0;
        leftslash[i+j] = 0;
        rightslash[j-i+7] = 0;
    }
}


在C语言中,解决N皇后问题可以采用递归回溯法。N皇后问题是经典的计算机科学问题,目标是在一个N×N的棋盘上放置N个皇后,使得任意两个皇后都不在同一行、同一列,以及对角线上。以下是递归函数的基本思路: 1. 定义一个函数`isSafe(row, col)`检查当前位置是否安全,即该位置的行、列和左上到右下的对角线范围内是否有其他皇后。 2. 定义主函数`nQueens(int n)`,它接受一个整数n作为棋盘大小。 - 初始化:设置当前皇后的位置`col = 0`,并传递一个二维数组`board`表示棋盘状态(默认初始化全零)。 - 调用`placeQueen(n, row, board)`尝试将皇后放在第`row`行。 - 如果成功放置,继续在下一个行尝试;如果失败(比如`isSafe()`返回false),回溯到前一行,移除当前皇后,然后尝试下一个位置。 - 当所有皇后都放置好,说明找到一种解,输出或记录这个解决方案。 - 如果`row == n`,表示已处理完所有行,结束递归。 下面是伪代码形式: ```c int isSafe(int row, int col, int board[N][N]) { // 检查列冲突 for (int i = 0; i < row; ++i) if (board[i][col] == 1) return 0; // 检查左上到右下对角线冲突 int leftDiag = col - row + N - 1; for (int i = 0; i < row; ++i) if (board[i][leftDiag] == 1) return 0; // 检查右上到左下对角线冲突 int rightDiag = col + row; for (int i = 0; i < row; ++i) if (board[i][rightDiag] == 1) return 0; return 1; } void placeQueen(int n, int row, int board[N][N]) { if (row >= n) { // 解决方案找到,打印或记录棋盘 printSolution(board); return; } for (int col = 0; col < n; ++col) { if (isSafe(row, col, board)) { board[row][col] = 1; placeQueen(n, row + 1, board); // 递归放置下一行皇后 board[row][col] = 0; // 回溯:移除当前皇后 } } } int main() { int n = ... // 输入棋盘大小 int board[n][n]; nQueens(n, 0, board); return 0; } ```
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值