UVA 12293 Box Game

There are two identical boxes. One of them contains n balls, while the other box contains one ball.

Alice and Bob invented a game with the boxes and balls, which is played as follows:


Alice and Bob moves alternatively, Alice moves first. For each move, the player finds out the box
having fewer number of balls inside, and empties that box (the balls inside will be removed forever),
and redistribute the balls in the other box. After the redistribution, each box should contain at least
one ball. If a player cannot perform a valid move, he loses. A typical game is shown below:


When both boxes contain only one ball, Bob cannot do anything more, so Alice wins.

Question: if Alice and Bob are both clever enough, who will win? Suppose both of them are very
smart and always follows a perfect strategy.

Input

There will be at most 300 test cases. Each test case contains an integer n (2 ≤ n ≤ 109) in a single
line. The input terminates by n = 0.
Output

For each test case, print a single line, the name of the winner.

Sample Input

2

3

4

0

Sample Output

Alice

Bob

Alice

题目的意思是,有两个盒子,一个盒子里有n个球,另外一个盒子里只有一个球,每一次将球数较少的盒子清空,然后分配球数较多的盒子中间的球。

我还是太天真了,我居然想着直接模拟出答案······压根就没有想到找规律这种事·····

然后  这个的规律就是  如果n==2^k-1,那么就是Bob赢,反之就是Alice赢

代码:

#include<stdio.h>
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        n++;
        while(n%2==0)//如果n+1是2的k次方的话,除到最后就剩下一个1了
            n/=2;
        if(n==1)
            printf("Bob\n");
        else
            printf("Alice\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值