Parity check——打表找规律+大数取模

Think:
1打表找规律,寻找循环节
2字符串存储大数+大数取模

SDUT题目链接

Parity check
Time Limit: 2000MS Memory Limit: 524288KB

Problem Description
Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=这里写图片描述

She is required to calculate f(n) mod 2 for each given n. Can you help her?

Input
Multiple test cases. Each test case is an integer n(0≤n≤) in a single line.

Output
For each test case, output the answer of f(n)mod2.

Example Input
2

Example Output
1

Hint

Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

以下为Accepted代码

#include <bits/stdc++.h>

using namespace std;

int main()
{
    char st[1004];
    int sum, i;
    while(scanf("%s", st) != EOF)
    {
        int len = strlen(st);
        sum = 0;
        for(i = len-1; i >= 0; i--){
            sum = (sum + (st[i] - '0')) % 3;///及时取模,避免数据储存超出限制
        }
        if(sum == 0)
            printf("0\n");
        else if(sum == 1 || sum == 2)
            printf("1\n");
    }
    return 0;
}


/***************************************************
User name: 
Result: Accepted
Take time: 0ms
Take Memory: 196KB
Submit time: 2017-05-11 21:42:35
****************************************************/
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值