Parity check(大数取模)

Parity check
Time Limit: 2000MS Memory Limit: 524288KB
Submit Statistic
Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:
f(n)=
She is required to calculate f(n) mod 2 for each given n. Can you help her?
Input

Multiple test cases. Each test case is an integer n(0≤n≤) in a single line.
Output

For each test case, output the answer of f(n)mod2.
Example Input

2
Example Output

1
Hint

Author

“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

找规律, 会发现%2, 每三位 就是0 1 1 因此 看是 %3 余几即可 但又因为是10^1000 因此是个大数 ,大数取模处理 就行

#include <bits/stdc++.h>
using namespace std;
int main()
{
    char m[12111];
    while(cin>>m)
    {
        int len = strlen(m);
        int sum = 0;
        for(int i=0;i<len;i++)//大数取模,核心
        {
            sum = (sum + m[i] - '0') % 3;
        }
        if(sum==1||sum==2)
            cout<<1<<endl;
        else
            cout<<0<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值