POJ 1753

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40019 Accepted: 17369

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw
wwww
bbwb
bwwb
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw
bwww
wwwb
wwwb
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source



题意:选定棋子的本身和该棋子上下左右相邻的棋子可变成相反的颜色。问最少选定几颗棋子可以让整个棋盘变成同一色。
做法用dfs对需要选定一个棋子两个棋子一直到十六个枚举
#include<stdio.h>
#include<string.h>
int flag;
int  arr[20][20];
int find(int x,int y)
{
    int xxx=arr[1][1];
    for(int i=1; i<=4; i++)
    {
        for(int j=1; j<=4; j++)
            if(arr[i][j]!=xxx)
                return 0;
    }
    return 1;
}
void change(int x,int y)
{
    arr[x][y]=!arr[x][y];
    arr[x-1][y]=!arr[x-1][y];
    arr[x+1][y]=!arr[x+1][y];
    arr[x][y-1]=!arr[x][y-1];
    arr[x][y+1]=!arr[x][y+1];
}
void f(int x,int y,int step,int n)//深搜
{
    if(step==n)
    {
        if(find(x,y))
            flag=1;
        return ;
    }
    if(flag||x==5)return ;
    change(x,y);
    if(y<4)
        f(x,y+1,step+1,n);
    else
        f(x+1,1,step+1,n);
    change(x,y);
    if(y<4)
        f(x,y+1,step,n);
    else
        f(x+1,1,step,n);
    return ;
}
int main()
{

      flag=0;
    char c;
    memset(arr,0,sizeof(arr));
    for(int i=1; i<=4; i++)
    {
        for(int j=1; j<=4; j++)
        {
            scanf("%c",&c);
            if(c=='b')
                arr[i][j]=1;
        }
        getchar();
    }
    for(int i=0; i<=16; i++)
    {
        f(1,1,0,i);
        if(flag)
        {
            printf("%d\n",i);
            break;
        }
    }
    if(!flag)
        printf("Impossible\n");


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值