题意:有一些虫子,编号1-n,输入数据给出互相交配的虫子,最后问有没有同性恋。。。。。。
思路:同POJ1703差不多的思想,假设现有a,b交配,则a与(b+n)同性,b与(a+n)同性,并查集构造同性关系;
输入数据的在线判断是否为同性;
A Bug's Life
Time Limit: 10000MS | Memory Limit: 65536K | |
Total Submissions: 34967 | Accepted: 11470 |
Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4
Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.
Source
TUD Programming Contest 2005, Darmstadt, Germany
#include<stdio.h>
#include<string.h>
int arr[2123*2];
int f(int x)
{
return arr[x]==x?x:arr[x]=f(arr[x]);
}
int main()
{
int t;
scanf("%d",&t);
for(int T=1;T<=t;T++)
{
int n,m;
scanf("%d%d",&n,&m);
for(int i=0;i<=2*n;i++)
{
arr[i]=i;
}
int flag=1;
while(m--)
{
int a,b;
scanf("%d%d",&a,&b);
if(flag)
{
if(f(a)==f(b))
{
flag=0;
}
else
{
arr[f(a)]=f(b+n);
arr[f(b)]=f(a+n);
}
}
}
if(T>1)
printf("\n");
printf("Scenario #%d:\n",T);
if(flag)
printf("No suspicious bugs found!\n");
else
printf("Suspicious bugs found!\n");
}
return 0;
}