poj 2142 The Balance

The Balance
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7295 Accepted: 3206

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

Source

Japan 2004


诶呦

这道题搞了有点久

其实把ax+by=c想成一条直线就好想多了



我们其实需要考虑的只有这四个点(|x|+|y|)

我们用扩欧分别求一下再比较就好了

先算出x为最小正整数时的x和y

如果这时y为正数

就可以把点往右移

取y为负数时的点

如果y已经为负数了

那么x,y同为正的点就已经不存在了

然后取y的最小正整数解

也这样做就可以了

#include<cstdio>
#include<cstring>
#define node __AA_node
int gcd(int a,int b,int &x,int &y)
{
	if(!b)
	{
		x=1,y=0;
		return a;
	}
	int d=gcd(b,a%b,y,x);y-=x*(a/b);
	return d;
}
struct node
{
	int x,y;
	int sum;
}e[5];
int main()
{
	int a,b,d;
	int x,y;
	scanf("%d %d %d",&a,&b,&d);
	while(a)
	{
		int dd=gcd(a,b,x,y);
		x*=d/dd;y*=d/dd;
		int l=b/dd,r=a/dd;
		//
		x=(x%l+l)%l;
		y=(d-a*x)/b;
		if(y>0)
		{
			e[3].x=x,e[3].y=y,e[3].sum=x+y;
			int t=y/r+1;
			y-=t*r;
			x+=t*l;
			e[1].x=x;e[1].y=-y;e[1].sum=x-y;
		}
		else
		{
			e[1].x=x;e[1].y=-y;e[1].sum=x-y;
			e[3].sum=2*1e9;
		}
		
		//
		y=(y%r+r)%r;
		x=(d-b*y)/a;
		if(x>0)
		{
			e[4].x=x;e[4].y=y;e[4].sum=x+y;
			int t=x/l+1;
			x-=t*l;
			y+=t*r;
			e[2].x=-x;e[2].y=y;e[2].sum=-x+y;
		}
		else
		{
			e[2].x=-x;e[2].y=y;e[2].sum=-x+y;
			e[4].sum=2*1e9;
		}
		
		//
		
		int kk=e[1].sum<e[2].sum?1:2;
		int qq=e[3].sum<e[4].sum?3:4;
		kk=e[kk].sum<e[qq].sum?kk:qq;
		printf("%d %d\n",e[kk].x,e[kk].y);
		scanf("%d %d %d",&a,&b,&d);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值