【hdu2456】aggresive cow——二分

题目:

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9488 Accepted: 4716

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS: 

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3. 

Huge input data,scanf is recommended.

Source

描述:在一维数轴上选择n个数可以接受对象,有c个对象,要求分配对象使相邻两个数的距离最大,且不相邻。

题解:先对n个数排序,之后求出间距的最大值,然后二分枚举间距尝试即可。

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;

const int N = 100005;
int arr[N];
int n, c;

bool jdg(int x)
{
	int num = arr[0];
	int i, j;
	j = 0;
	for (i = 1; i<c; i++)
	{
		num += x;
		bool flag = false;
		for (j++; j<n; j++)                  //由于退出是break,上一次查询并没有更新j,所以初始化时j++
			if (num <= arr[j])           //经过距离x后的编号小于等于有牛的房间
			{
				num = arr[j];        //从这个房间起算
				flag = true;
				break;
			}
		
		if (flag == false)
			return false;
	}
	return true;
}

int main()
{
	//freopen ("input.txt", "r", stdin);
	int i;
	while (~scanf("%d%d", &n, &c))
	{
		for (i = 0; i<n; i++)
			scanf("%d", &arr[i]);
		sort(arr, arr + n);
		int left, right, mid;
		right = (arr[n - 1] - arr[0]) / (c - 1);
		left = 0;
		while (left <= right)
		{
			mid = (left + right) / 2;
			if (jdg(mid))
				left = mid + 1;
			else
				right = mid - 1;
		}
		printf("%d\n", right);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值