【poj1905】Expanding Rods——二分

题目:

Expanding Rods
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 14196 Accepted: 3697

Description

When a thin rod of length L is heated n degrees, it expands to a new length L'=(1+n*C)*L, where C is the coefficient of heat expansion. 
When a thin rod is mounted on two solid walls and then heated, it expands and takes the shape of a circular segment, the original rod being the chord of the segment. 

Your task is to compute the distance by which the center of the rod is displaced. 

Input

The input contains multiple lines. Each line of input contains three non-negative numbers: the initial lenth of the rod in millimeters, the temperature change in degrees and the coefficient of heat expansion of the material. Input data guarantee that no rod expands by more than one half of its original length. The last line of input contains three negative numbers and it should not be processed.

Output

For each line of input, output one line with the displacement of the center of the rod in millimeters with 3 digits of precision. 

Sample Input

1000 100 0.0001
15000 10 0.00006
10 0 0.001
-1 -1 -1

Sample Output

61.329
225.020
0.000

描述:物理题,两堵墙之前是一根长为L的可膨胀的杆,给出热膨胀系数以及运算方法,墙不会动所以杆会向上拱起,求拱起的最大高度。

题解:这里要注意杆式均匀地,重心就在重点,膨胀也是均匀膨胀,所以L膨胀之后的形状就是一段圆弧。二分枚举中间拱起的高度,根据三角公式算出圆弧所在圆的半径,得出反余切值,即圆心角的弧度,然后弧长=圆心角*半径,比较这个值和实际的L'。

代码:

#include <stdio.h>
#include <math.h>

double Low, High, Mid, theta, R;

int main()
{
	double L, T, C, L2;
	while (scanf("%lf%lf%lf", &L, &T, &C))
	{
		if (L<0 && T<0 && C<0) break;
		if (L == 0 || T == 0 || C == 0)
		{
			puts("0.000");
			continue;
		}
		L2 = L + T*C*L;
		Low = 0;
		High = L / 2;
		while (High - Low > 1e-4)
		{
			Mid = (High + Low) / 2;
			R = Mid / 2 + L*L / 8 / Mid;
			theta = acos(1 - L*L / R / R / 2);
			if (theta*R >= L2)
				High = Mid;
			else Low = Mid;
		}
		printf("%.3lf\n", Mid);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值