【hdu2298】Toxophily——三分+二分

9 篇文章 0 订阅
2 篇文章 0 订阅

题目:

Toxophily

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1603    Accepted Submission(s): 853


Problem Description
The recreation center of WHU ACM Team has indoor billiards, Ping Pang, chess and bridge, toxophily, deluxe ballrooms KTV rooms, fishing, climbing, and so on.
We all like toxophily.

Bob is hooked on toxophily recently. Assume that Bob is at point (0,0) and he wants to shoot the fruits on a nearby tree. He can adjust the angle to fix the trajectory. Unfortunately, he always fails at that. Can you help him?

Now given the object's coordinates, please calculate the angle between the arrow and x-axis at Bob's point. Assume that g=9.8N/m. 
 

Input
The input consists of several test cases. The first line of input consists of an integer T, indicating the number of test cases. Each test case is on a separated line, and it consists three floating point numbers: x, y, v. x and y indicate the coordinate of the fruit. v is the arrow's exit speed.
Technical Specification

1. T ≤ 100.
2. 0 ≤ x, y, v ≤ 10000. 
 

Output
For each test case, output the smallest answer rounded to six fractional digits on a separated line.
Output "-1", if there's no possible answer.

Please use radian as unit. 
 

Sample Input
  
  
3 0.222018 23.901887 121.909183 39.096669 110.210922 20.270030 138.355025 2028.716904 25.079551
 

Sample Output
  
  
1.561582 -1 -1
 

Source



代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;
const double eps = 1e-8;
const int maxn = 10005;
const double g = 9.8;
const double pi = acos(-1.0);
int r[maxn];
double f(double t, double x, double y, double v)
{
	return x*tan(t) - x*x*g / 2  / v / v / cos(t) / cos(t);
}
int main()
{
	//freopen("input.txt", "r", stdin);
	int T;
	scanf("%d", &T);
	while (T--)
	{
		double x, y, v0;
		scanf("%lf%lf%lf", &x, &y, &v0);
		double l = 0.0;
		double r = pi / 2;
		while (r - l > eps)
		{
			double mid1 = (l + r) / 2;
			double mid2 = (mid1 + r) / 2;
			if (f(mid1, x, y, v0) > f(mid2, x, y, v0))
				r = mid2;
			else
				l = mid1;
		}
		if (f(r, x, y, v0) < y)
		{
			puts("-1");
			continue;
		}
		l = 0.0;
		while (r - l > eps)
		{
			double mid = (l + r) / 2;
			if (f(mid, x, y, v0) > y + eps)
				r = mid;
			else
				l = mid;
		}
		printf("%.6lf\n", r);
	}
	return 0;
}
描述:给定斜抛运动的起点和目标点,求一个最小角度,使得能恰好击中目标。

题解:考虑斜抛运动的轨迹与x = x0(即给定目标的横坐标所在直线)的交点的纵坐标与theta的关系,列出函数:f(theta) = x*tan(t) - x*x*g / 2  / v / v / cos(t) / cos(t)。

画出图象:

发现在(0,pi/2)是单峰函数,所以使用三分法找到y的最大值,如果这个最大值都不能满足目标则输出-1,如果可以,则再二分找到接近y的角度,因为要找最小的角度,所以在(0,mid)之间二分即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值