【hdu1867】A + B for you again——KMP

题目:

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5914    Accepted Submission(s): 1463


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source

描述:两个字符串拼接,如果前缀后缀匹配就压缩,按字典序输出

题解:注意这俩先后关系不确定,所以kmp跑两遍,还有kmp在匹配的时候pattern串不要走完就停,因为是前缀后缀的匹配,所以只能是text串走到完

代码:

#include <stdio.h>
#include <string.h>

int next[100005];

void getnext(char str[])
{
    int i = 1,j = 0;
    int len = strlen(str);
    next [0] = -1;
    while(i < len)
    {
        if(j == -1 || str[i] == str[j])
        {
            i++;
            j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}

int kmp(char str1[],char str2[])
{
    int i= 0,j = 0;
    int len1 = strlen(str1),len2 = strlen(str2);
    getnext(str2);
    while(i<len1)
    {
        if(j == -1 || str1[i] == str2[j])
        {
            i++;
            j++;
        }
        else
            j = next[j];
    }
    if(i == len1)            //看串1遍历完之后串2可以匹配到哪个位置
        return j;
    return 0;
}

int main()
{
    int x,y;
    char str1[100005],str2[100005];
    while(scanf("%s%s",str1,str2)!=EOF)
    {
        x = kmp(str1,str2);
        y = kmp(str2,str1);
        if(x == y)
        {
            if(strcmp(str1,str2)>0)
            {
                printf("%s",str2);
                printf("%s\n",str1+x);
            }
            else
            {
                printf("%s",str1);
                printf("%s\n",str2+x);
            }
        }
        else if(x>y)
        {
            printf("%s",str1);
            printf("%s\n",str2+x);
        }
        else
        {
            printf("%s",str2);
            printf("%s\n",str1+y);
        }
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值