HDOJ 1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 314862    Accepted Submission(s): 61064


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input2
1 2
112233445566778899 998877665544332211
 

Sample Output
Case 1:
1 + 2 = 3


Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


**********************************************************************************************************************************************************

用字符串存数,然后逐个转化为数字,模拟加法,很关键的一点是因为加法是从最后一位加的,所以转化为数字时倒着存,要方便许多,如果正着存还要根据数字的长度对齐加。加完了别忘了判断后一位是不是0,看看是否进位了,不是0也要输出。输出倒序输出就行了。
代码如下:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int max(int x,int y)
{    
    int m;
    m=x>y?x:y;//求大的数 
    return m;
}
int main()
{
    int a[1100],b[1100],n,t=0,lena,lenb,i,z;
    char cha[1100],chb[1100];
    scanf("%d",&n);
    while(n--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%s%s",&cha,&chb);
        lena=strlen(cha);
        lenb=strlen(chb);
        z=max(lena,lenb);
        for(i=0;i<lena;i++)
        {
            a[lena-1-i]=cha[i]-'0';
        }
        for(i=0;i<lenb;i++)
        {
        b[lenb-1-i]=chb[i]-'0';
        }
        for(i=0;i<z;i++)
        {
            a[i]+=b[i];
            if(a[i]>9)//进位 
            {
            a[i]-=10;
            a[i+1]++;
            }
        }
        t++;
        printf("Case %d:\n",t);
        printf("%s + %s = ",cha,chb);
        if(a[z]!=0)
        {
        for(i=z;i>=0;i--)
        printf("%d",a[i]);
        printf("\n");
        }
        else
        {
        for(i=z-1;i>=0;i--)
        printf("%d",a[i]);    
        printf("\n");
        }
        if(n!=0)
        printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值