杭电1002 大数相加

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 


Sample Input
2
1 2
112233445566778899 998877665544332211
 


Sample Output
Case 1:
1 + 2 = 3


Case 2:

112233445566778899 + 998877665544332211 = 1111111111111111110


解题策略:

此题细节方面一定要注意。

1.用字符数组装数字。

2.字符型不可以和数值型一样相加减,先转换成数值型,即减去‘0’或者减去0的ASCLL码值也可以。

3.细节方面的空格一定注意,否则一直PE。


#include<stdio.h>
#include<math.h>
#include<ctype.h>
#include<string.h>
#define MAXN 5000

int max(int lena,int lenb)
{
	return (lena>=lenb?lena:lenb);
}

int main()
{
	int k,lena,lenb,T,i,j,num;
	char a[MAXN],b[MAXN],sum[MAXN];
	scanf("%d",&T);
	k=1;
	while(T--)
	{
		memset(sum,0,sizeof(sum));
		scanf("%s",a);
		scanf("%s",b);
		lena=strlen(a);
		lenb=strlen(b);
		num=max(lena,lenb);
		for(i=lena-1;i>=0;i--)
		{
			sum[lena-i-1]+=a[i]-'0';  //字符型不可以和数值型一样相加减,要先转换成数值型 
		}
		for(i=lenb-1;i>=0;i--)
		{
			sum[lenb-i-1]+=b[i]-'0';
		}
		for(i=0;i<=num;i++)
		{
			if(sum[i]>=10)
			{
				sum[i]-=10;
				sum[i+1]++;	
			}
			
		}
		for(i=num;i>=0;i--)
		{
			if(sum[i])
			break;
		}
		printf("Case %d:\n",k++);
		printf("%s + %s = ",a,b);  //数字之前要有空格,很坑爹,很细节 
		for(j=i;j>=0;j--)
		{
			printf("%d",sum[j]);
		}
		printf("\n");  //一定要仔细观察格式问题,因为没有注意到这里还有空行,WA了两次,一直PE 
		if(T)   //这个地方也是一个注意怎么处理回车的问题 
		printf("\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值