HDOJ 1003 Max Sum

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 217241    Accepted Submission(s): 51243


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 从第一个数开始依次往后加,如果遇到加上后面一个数的结果没有后面一个数的本身大的情况,就以后面那个数为开头开始新的序列。最后找到值最大的序列。序列的末尾好判断,开头需要从末尾开始加到这个序列的第一个数,找到最后一个使和等于最大值的下标。就是序列的开头。
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[100000+100],dp[100000+100];
int main()
{
	int t,cnt;
	scanf("%d",&t);
	cnt=0;
	while(t--)
	{	
		int n,maxn,maxe,maxb,sum;
		scanf("%d",&n);
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);
		dp[1]=a[1];
		maxn=dp[1];
		maxe=1;
		for(int i=2;i<=n;i++)
		{
			dp[i]=max(dp[i-1]+a[i],a[i]);
			if(dp[i]>=maxn)
			{
				maxn=dp[i];
				maxe=i;
			}	
		}
		sum=0;
		maxb=maxe;
		for(int i=maxe;i>=1;i--)
		{
		sum+=a[i];
		if(sum==maxn)
			maxb=i;
		}
		printf("Case %d:\n%d %d %d\n",++cnt,maxn,maxb,maxe);
		if(t!=0)
		printf("\n");
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值