HDOJ 1789 Doing Homework again

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11637    Accepted Submission(s): 6837


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 
贪心算法,根据分值大小排序大的优先如果那天空闲就安排在那天,如果不空闲就向前推,如果前面也没有那就扣分呗。刚接触贪心,感觉理解的不透彻。摸不准怎样才是局部最优。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct WORK
{
	int t;
	int s;
}wok[1010];
int cmp(WORK a,WORK b)
{
	return a.s>b.s;
}
int main()
{
	int t,n,i,j,sum,a[1010],flag;
	scanf("%d",&t);
	while(t--)
	{	
		memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&wok[i].t);
		for(i=0;i<n;i++)
			scanf("%d",&wok[i].s);
		sort(wok,wok+n,cmp);
		/*for(i=0;i<n;i++)
			printf("%d ",wok[i].t);
			printf("\n");
		for(i=0;i<n;i++)
			printf("%d ",wok[i].s);*/
		sum=0;
		for(i=0;i<n;i++)
		{
			if(a[wok[i].t]==0)
			{
			a[wok[i].t]=1;
			continue;
			}
			if(a[wok[i].t]!=0)
			{	
				flag=0;
				for(j=wok[i].t-1;j>0;j--)
				{
					if(a[j]==0)
					{
					a[j]=1;
					flag=1;
					break;
					}
				}
				if(flag==0)
				sum+=wok[i].s;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}


 

weixin063传染病防控宣传微信小程序系统的设计与实现+springboot后端毕业源码案例设计 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值