1.暴力(普通)匹配算法(BP算法)
/*
BP(Bruth-Force)算法, 简单的模式匹配算法
最好的平均时间复杂度O(n+m)
最坏的平均时间复杂度O(n*m)
主串长度为n,子串长度为m
*/
int Index_BF(string S, string T, int pos)
{//从S的pos位置开始,返回子串T在S中第一次出现的位置序号,未出现则返回-1
int i = pos, j = 0; //i,j分别指示S和T当前正待比较的字符位置
while(i < S.length() && j < T.length())
{
if(S[i] == T[j]){
i++;
j++;
}
else{//i,j均回溯
i = i - j + 1;
j = 0;
}
}
if(j >= T.length()) return i - T.length();
else return -1;
}
2.KMP算法
//KMP算法(MP)
//时间复杂度O(n+m)
void getFail(string P, int *f)
{//P为子串,f为匹配失败时j返回位置的数组
//思想:P自己和自己匹配
int m = P.length();
f[0] = 0; f[1] = 0;//递推边界初值,j = 0, i = 1
for(int i = 1; i < m; i++)
{
int j = f[i];
while(j && P[i] != P[j]) j = f[j];
if(P[i] == P[j]) f[i+1] = j+1;
else f[i+1] = 0;
}
}
int find(string T, string P, int *f)
{//返回子串P在T中第一次出现的位置序号,未出现则返回-1
//T为文本串,P为子串,f为匹配失败时j返回位置的数组
int pos = -1;
int n = T.length(), m = P.length();
getFail(P, f);
int j = 0; //当前子串位置,初始为0
for(int i = 0; i < n; i++)
{//i为文本串当前位置
while(j && P[j] != T[i]) j = f[j]; //j回溯
if(P[j] == T[i]) j++;
if(j == m) {
pos = i - m + 1;//找到
return pos;
}
}
return pos;
}
题目:HDU 1686 (传送门)
Oulipo
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive ‘T’s is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
//PS:KMP裸题
#include<iostream>
using namespace std;
const int maxn = 1e4;
int ans;
void getFail(string P, int *f)
{
int m = P.length();
f[0] = 0; f[1] = 0;
for(int i = 1; i < m; i++)
{
int j = f[i];
while(j && P[i] != P[j]) j = f[j];
if(P[i] == P[j]) f[i+1] = j+1;
else f[i+1] = 0;
}
}
void find(string T, string P, int *f)
{
int pos = -1;
int n = T.length(), m = P.length();
getFail(P, f);
int j = 0;
for(int i = 0; i < n; i++)
{
while(j && P[j] != T[i]) j = f[j];
if(P[j] == T[i]) j++;
if(j == m) {
ans++;
}
}
}
int main()
{
ios::sync_with_stdio(false);
int n;
cin>>n;
while(n--)
{
ans = 0;
string T, W;
cin>>T>>W;
int f[maxn];
find(W,T,f);
cout<<ans<<endl;
}
return 0;
}