HDU 1212 Big Number(大整数取模)

11 篇文章 1 订阅
5 篇文章 0 订阅

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

As we know, Big Number isalways troublesome. But it's really important in our ACM. And today, your taskis to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains lessthan 25 lines.

Input

The input contains several test cases. Each test case consistsof two positive integers A and B. The length of A will not exceed 1000, and Bwill be smaller than 100000. Process to the end of file.

Output

For each test case, you haveto ouput the result of A mod B.

Sample Input

2 3
12 7
152455856554521 3250

Sample Output

2
5
1521

Author

Ignatius.L

Source

杭电ACM省赛集训队选拔赛之热身赛

ps: 将大整数用字符串表示,逐步取模。比如 : 123 % 5, 可以用下面步骤分解
1 % 5 = (0 * 10 + 1) % 5 = (0 % 5 * 10 + 1) % 5 ;
12 % 5 = (1 * 10 + 2) % 5 = ( 1 % 5 * 10 + 2 ) % 5 ;

123 % 5 = (12 * 10 + 3) % 5 = (12 % 5 * 10+ 3) % 5 ;

#include<iostream>
#include<string>
#define ll long long
using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    string num;
    int n;
    while(cin>>num>>n)
    {
        ll ans = 0;
        int len_num = num.length();
        for(int i = 0; i < len_num; i++)
        {
            ans = (ans * 10 + num[i] - '0') % n;
        }
        cout<<ans<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值