Big Number

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7329    Accepted Submission(s): 5060


Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
  
  
2 3 12 7 152455856554521 3250
 

Sample Output
  
  
2 5 1521
大数取余现在遇到了两种,一种是A^BmodC,这种用快速幂求解,有固定的模板,而现在这种是大数Amod B,B是int型,A是个大数,可能无法直接存储,可以用字符串来保存,可以设置变量t从大数的第一位向后遍历赋值,如果大于mod就取余更新,就像数学计算一样。
例:123mod6,取中间变量t,1<6,t=1;
-2t=1乘10+2%6=0 t=0;
-3t=0乘10+3%6=3;t=3;
<span style="font-size:18px;">#include<cstdio>
#include<cstring>
int main()
{
	long long b,i,s,h,j;
	char a[1100];
	while(scanf("%s%lld",a,&b)!=EOF)
	{
		s=0;j=0;
		h=strlen(a);
		for(i=0;i<h;i++)
		{
			s=s*10+(a[i]-'0');
			s%=b;
		}
		
		printf("%lld\n",s);
	}
	return 0;
}</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值