1684: [Usaco2005 Oct]Close Encounter

1684: [Usaco2005 Oct]Close Encounter

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 423   Solved: 199
[ Submit][ Status][ Discuss]

Description

Lacking even a fifth grade education, the cows are having trouble with a fraction problem from their textbook. Please help them. The problem is simple: Given a properly reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1, so the fraction cannot be further reduced) find the smallest properly reduced fraction with numerator and denominator in the range 1..32,767 that is closest (but not equal) to the given fraction. 找一个分数它最接近给出一个分数. 你要找的分数的值的范围在1..32767

Input

* Line 1: Two positive space-separated integers N and D (1 <= N < D <= 32,767), respectively the numerator and denominator of the given fraction

Output

* Line 1: Two space-separated integers, respectively the numerator and denominator of the smallest, closest fraction different from the input fraction.

Sample Input

2 3

Sample Output

21845 32767

OUTPUT DETAILS:

21845/32767 = .666676839503.... ~ 0.666666.... = 2/3.

HINT

Source

 

题意是找一个最接近但不相等的分数。。然后注意精度

判断(a/b)==(x/y)使用ay==bx...

#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;

typedef double DB;

DB v,now,M;
int a,b,i,j,a1,a2;

void Judge(int x,int y)
{
	DB V = (DB)(x) / (DB)(y);
	if (abs(V - v) < M)
	{
		if (x * b == y * a) return;
		M = abs(V-v);
		a1 = x; a2 = y;
	}
}

int main()
{
	cin >> a >> b;
	v = (DB)(a) / (DB)(b);
	M = 1E5;
	for (i = 1; i <= 32767; i++)
	{
		int k = (DB)(a) / (DB)(b) * (DB)(i);
		Judge (k-1,i); Judge(k,i); Judge(k+1,i);
	}
	printf("%d %d",a1,a2);
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值