bzoj1684 [Usaco2005 Oct]Close Encounter

57 篇文章 0 订阅

Description

Lacking even a fifth grade education, the cows are having trouble with a fraction problem from their textbook. Please help them. The problem is simple: Given a properly reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1, so the fraction cannot be further reduced) find the smallest properly reduced fraction with numerator and denominator in the range 1..32,767 that is closest (but not equal) to the given fraction. 找一个分数它最接近给出一个分数. 你要找的分数的值的范围在1..32767

Input

* Line 1: Two positive space-separated integers N and D (1 <= N < D <= 32,767), respectively the numerator and denominator of the given fraction

Output

* Line 1: Two space-separated integers, respectively the numerator and denominator of the smallest, closest fraction different from the input fraction.

Sample Input

2 3

Sample Output

21845 32767

OUTPUT DETAILS:

21845/32767 = .666676839503.... ~ 0.666666.... = 2/3.

题意是给定一个分数a/b,求和它最接近的分数x/y。只要限制1<=x,y<=32767就行了

我们从1到32767枚举分母j,然后显然和a/b最相近的分数一定是i/j和(i+1)/j。至于怎么算自己脑补一下就行,很简单

有一个问题是判定i/j和a/b是否完全相等,如果怕被卡精度可以直接判定(i*b==j*a)是否成立就行了。这也很简单,就是移项一下

然后没有了

#include<cstdio>
#include<cmath>
int a,b,i,aa,bb;
double save=10;
inline double abs(double x)
{if (x<0)x=-x;return x;}
void jud(int x,int y)
{
	if (x*b==y*a) return;
	double work=abs((double)x/y-(double)a/b);
	if (work<save)
	{
		save=work;
		aa=x;
		bb=y;
	}
}
int main()
{
	scanf("%d%d",&a,&b);
	for (int j=1;j<=32767;j++)
	  {
	  	i=(int)floor((double)a/b*j);
	  	jud(i,j);
	  	jud(i+1,j);
	  }
	printf("%d %d\n",aa,bb);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值