POJ 2185 Milking Grid

Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

Input
* Line 1: Two space-separated integers: R and C 

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character. 
Output
* Line 1: The area of the smallest unit from which the grid is formed
Sample Input
2 5
ABABA
ABABA
Sample Output
2

Hint

The entire milking grid can be constructed from repetitions of the pattern 'AB'.

题意:给你一个R*C的矩阵,让你求它的最小子矩阵;

思路:用kmp分别算出每行的最小循环节,再求出列的最小循环管节,再求出每行的最小循环节的最小公倍数和每列的最小循环节的最小公倍数,结果就是两个数的乘积。

代码如下慢慢体会吧:
#include<stdio.h>
int next[10005];

void Get_next(int x , char *c)
{
next[0] = -1;
for(int i = 1; i < x; i++)
{
int k = next[i-1];
while(c[k+1] != c[i] && k >= 0)
k = next[k];
if(c[k+1] == c[i])
next[i] = k+1;
else
next[i] = -1;
}
}


int gcd(int m , int n)//最大公约数 
{
if(m % n == 0) return n;
else return gcd(n , m % n);
}


int lcm(int m , int n)//最小公倍数 
{
return m/gcd(m , n) * n;
}


int main()
{
int n = 1,m = 1;
int r,c;
char c1[10005][80];
char c2[80];
char c3[10005];
scanf("%d %d",&r,&c);
for(int i = 0; i < r; i++)//求行的最小循环节 
{
scanf("%s",c1[i]);
for(int j = 0; j < c; j++)
c2[j] = c1[i][j];
Get_next(c , c2);
n = lcm(n , c - next[c - 1] - 1);
if(n > c)
n = c;
}
for(int i = 0; i < c; i++)//求列的最小循环节 
{
for(int j = 0; j < r; j++)
c3[j] = c1[j][i];
Get_next(r , c3);
m=lcm(m , r-next[r-1]-1);
if(m > r)
m = r;
}

printf("%d\n",m*n);
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值