POJ2185 Milking Grid

POJ2185 Milking Grid
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 3220 Accepted: 1317

Description

Every morning when they are milked, the Farmer John's cows form a rectangular grid that is R (1 <= R <= 10,000) rows by C (1 <= C <= 75) columns. As we all know, Farmer John is quite the expert on cow behavior, and is currently writing a book about feeding behavior in cows. He notices that if each cow is labeled with an uppercase letter indicating its breed, the two-dimensional pattern formed by his cows during milking sometimes seems to be made from smaller repeating rectangular patterns. 

Help FJ find the rectangular unit of smallest area that can be repetitively tiled to make up the entire milking grid. Note that the dimensions of the small rectangular unit do not necessarily need to divide evenly the dimensions of the entire milking grid, as indicated in the sample input below. 

Input

* Line 1: Two space-separated integers: R and C 

* Lines 2..R+1: The grid that the cows form, with an uppercase letter denoting each cow's breed. Each of the R input lines has C characters with no space or other intervening character. 

Output

* Line 1: The area of the smallest unit from which the grid is formed 

Sample Input

2 5
ABABA
ABABA

Sample Output

2

Hint

The entire milking grid can be constructed from repetitions of the pattern 'AB'.
********************************************************************
只不过这题让我明白了P数组可以来求一个字符串的重复字串。
#include <stdio.h>
#include <string.h>
#include <vector>
#define R 10005
#define C 80
using namespace std;

int r,c;
char gra[R][C],te[R];
int p[R],mark[R];

void KMP(int a,int b)
{
    memset(p,-1,sizeof(p));
    for(int i=1;i<b;i++)
    {
        int k=p[i-1];
        while(1)
        {
            if(te[k+1]==te[i])
            {
                p[i]=k+1;
                break;
            }
            if(k==-1)break;
            k=p[k];
        }
    }
    int k=p[b-1];
    while(1)
    {
        mark[b-1-k]++;
        if(k==-1)break;
        k=p[k];
    }
}

void re(void)
{
    scanf("%d%d",&r,&c);
    getchar();
    for(int i=0;i<r;i++)
        gets(gra[i]);
}

void run(void)
{
    memset(mark,0,sizeof(mark));
    for(int i=0;i<r;i++)
    {
        for(int j=0;j<c;j++)
            te[j]=gra[i][j];
        KMP(i,c);
    }
    int ans1,ans2;
    for(ans1=1;ans1<=c;ans1++)
        if(mark[ans1]==r)
            break;
    memset(mark,0,sizeof(mark));
    for(int i=0;i<c;i++)
    {
        for(int j=0;j<r;j++)
            te[j]=gra[j][i];
        KMP(i,r);
    }
    for(ans2=1;ans2<=r;ans2++)
        if(mark[ans2]==c)
            break;
    printf("%d\n",ans1*ans2);
}

int main()
{
    //freopen("/home/fatedayt/in","r",stdin);
    re();
    run();
    return 0;
}

  

转载于:https://www.cnblogs.com/Fatedayt/archive/2011/12/04/2275487.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值