HDU - 5918 Sequence I

Mr. Frog has two sequences  a1,a2,,an a1,a2,⋯,an and  b1,b2,,bm b1,b2,⋯,bm and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm b1,b2,⋯,bm is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p aq,aq+p,aq+2p,⋯,aq+(m−1)p where  q+(m1)pn q+(m−1)p≤n and  q1 q≥1.
Input
The first line contains only one integer  T100 T≤100, which indicates the number of test cases. 

Each test case contains three lines. 

The first line contains three space-separated integers  1n106,1m106 1≤n≤106,1≤m≤106 and  1p106 1≤p≤106

The second line contains n integers  a1,a2,,an(1ai109) a1,a2,⋯,an(1≤ai≤109)

the third line contains m integers  b1,b2,,bm(1bi109) b1,b2,⋯,bm(1≤bi≤109).
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
Sample Input
2
6 3 1
1 2 3 1 2 3
1 2 3
6 3 2
1 3 2 2 3 1
1 2 3
Sample Output
Case #1: 2

Case #2: 1

有规律的暴力,直接求答案:

#include <stdio.h>
const int maxn = 1e6+5;
int a[maxn];
int b[maxn];
int main() {
	int N;
	int n , m , p;
	scanf("%d",&N);
	int M = N;
	while(N--) {
		int sum = 0 , flag;
		scanf("%d %d %d",&n, &m, &p);
		for(int i = 0; i < n; i++)
		scanf("%d",&a[i]);
		for(int i = 0; i < m; i++)
		scanf("%d",&b[i]);
		for(int j = 0; j <= (n - m*p + p - 1); j++) {
			if(a[j] == b[0]) {
				flag = 0;
				for(int k = 1; k < m; k++) {
					if(b[k] != a[j + k*p]) {
						flag = 1;
						break;
					}
				}	
				if(flag == 0)
				sum++;
			}
		}
		printf("Case #%d: %d\n",M - N, sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值