2016 ccpc长春现场赛I Sequence I(hdu 5918)

2 篇文章 0 订阅


Sequence I

Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
Mr. Frog has two sequences  a1,a2,,an  and  b1,b2,,bm  and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm  is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p  where  q+(m1)pn  and  q1 .
 

Input
The first line contains only one integer  T100 , which indicates the number of test cases.

Each test case contains three lines.

The first line contains three space-separated integers  1n106,1m106  and  1p106 .

The second line contains n integers  a1,a2,,an(1ai109) .

the third line contains m integers  b1,b2,,bm(1bi109) .
 

Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
 

Sample Input
  
  
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 1
 

Statistic |  Submit |  Clarifications |  Back
题意:给你两个数组,再给你距离间隔,要求你用第一个数组以一定的距离间隔匹配第二个数组,问有多少种匹配方案。

思路:现场赛的时候这道题可以暴力O(n*m)过的,但估计这道题想考的是kmp,把kmp模板改一下就好了,kmp的时间复杂度是O(n),别问我为什么暴力比kmp速度更快。下面给代码

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
typedef long long LL;
using namespace std;
#define inf 0x3f3f3f3f
#define maxn 100005
typedef long long LL;
int num, sum, n, m;
int next1[maxn], P[maxn], T[maxn];
void makeNext()
{
	int q, k;
	next1[0] = 0;
	for (q = 1, k = 0; q < m; ++q)
	{
		while (k > 0 && P[q] != P[k])
			k = next1[k - 1];
		if (P[q] == P[k])
		{
			k++;
		}
		next1[q] = k;
	}
}
void kmp()
{
	int i, q;
	makeNext();
	for (int st = 0; st < num; st++){
		for (i = st, q = 0; i < n; i += num)
		{
			while (q > 0 && P[q] != T[i])
				q = next1[q - 1];
			if (P[q] == T[i])
			{
				q++;
			}
			if (q == m)
			{
				sum++;
			}
		}
	}
}
int main(){
	int t;
	scanf("%d", &t);
	for (int tcase = 1; tcase <= t; tcase++){
		memset(P, 0, sizeof(P));
		memset(T, 0, sizeof(T));
		scanf("%d%d%d", &n, &m, &num);
		for (int i = 0; i<n; i++){
			scanf("%d", &T[i]);
		}
		for (int i = 0; i<m; i++){
			scanf("%d", &P[i]);
		}
		sum = 0;
		kmp();
		printf("Case #%d: %d\n", tcase, sum);
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值