HDU - 5916 Harmonic Value Description

The harmonic value of the permutation  p1,p2,pn p1,p2,⋯pn is 
i=1n1gcd(pi.pi+1) ∑i=1n−1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
Input
The first line contains only one integer T ( 1T100 1≤T≤100), which indicates the number of test cases. 

For each test case, there is only one line describing the given integers n and k ( 12kn10000 1≤2k≤n≤10000).
Output
For each test case, output one line “Case #x:  p1 p2  pn p1 p2 ⋯ pn”, where x is the case number (starting from 1) and  p1 p2  pn p1 p2 ⋯ pn is the answer.
Sample Input
2
4 1
4 2
Sample Output
Case #1: 4 1 3 2
Case #2: 2 4 1 3
 
 
:题意说的很清楚,2k <= n;所以不用考虑 ∑i=1n−1gcd(pi.pi+1) 过大,或者说突然增大的情况,因为必然存在最小,第二小,第三小,第k小;
最小时,我们只需要让∑i=1n−1gcd(pi.pi+1) = n-1,第二小时,只需要将某一组的gcd(pi,pi+1)=2即可
同理,继续增加也是一样的;而我们知道,一个偶数和奇数的gcd永远是1,并且相邻的两个偶数之间的gcd
是2,两个相邻的奇数的gcd是1,所以我们只要知道k,就把几个连续的2的倍数放在前面,然后后面的数不
变。
#include <stdio.h>
#include <string.h>
int main(int argc, char const *argv[])
{
	int  N , n , k;
	int a[10005] , sum = 0;
	scanf("%d",&N);
	while(N--) {
		scanf("%d%d",&n , &k);
		memset(a, 0, sizeof(a));
		for(int i = 1; i <= k; i++) {
			a[i*2] = 1;
		}
		printf("Case #%d:",++sum);
		for(int i = 1; i <= n; i++) 
			if(a[i]) printf(" %d",i);
		for(int i = 1; i <= n; i++) 
			if(!a[i]) printf(" %d",i);
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值