POJ - 1852 Ants

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 
Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output
4 8
38 207
题意:n只蚂蚁都以相同的速度1cm/s在长度为L的杆子上爬行,当蚂蚁爬到杆子的端点之后会掉落,两只蚂蚁相遇后会朝向相反的方向移动,现在给你n只蚂蚁的初始位置,但是不给他们的朝向,问所有蚂蚁在杆子上面移动的最短时间和最长时间。
对于最小时间,因为每只蚂蚁速度相同,所以最小的时间就是靠近中间的蚂蚁,让他们都超两边走,所以只需要找到最靠近杆中间的蚂蚁就行了。
对于最长时间,因为蚂蚁相遇后会朝向相反的方向移动,但是你会发现无论怎么相遇也不会改变蚂蚁在杆上运动的时间,也就是说一只蚂蚁在杆上运动的时间是只与他所在的位置和杆长有关,不和蚂蚁的数量有任何关系!所以我们只需要排个序比较一下jiuxin
具体代码如下:
#include <stdio.h>
#define inf 0x3f3f3f3f
int abs(int x) {
	return x>0?x:-x;
}
int main() {
	int N;
	int L, n, p;
	int mx, mn, m;//mx 位置的最大值 mn 最小值 m 中间值 
	scanf("%d",&N);
	while(N--) {
		mx = 0, mn = inf, m = inf;
		scanf("%d%d",&L, &n);
		for(int i = 0; i < n; i++) {
			scanf("%d",&p);
			if(m > abs(L - 2*p))
			m = abs(L-2*p);
			if(mn > p) mn = p;
			if(mx < p) mx = p;
		}
		mx = (L-mn)>mx?(L-mn):mx;
		mn = (L-m)/2;
		printf("%d %d\n",mn,mx);
	}
	return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值