POJ 3268 Silver Cow Party

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively:  NM, and  X 
Lines 2..  M+1: Line  i+1 describes road  i with three space-separated integers:  Ai, Bi, and  Ti. The described road runs from farm  Ai to farm  Bi, requiring  Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

题意:牛还要参加聚会。。。给N个牛,M个路径输入。问其他的牛去找X牛,并且返回到自己家的最短总路程,求除了X外的其他牛的最短路的最大值。
样例解释:第一行:N,M,X  N个牛, 接下来M个输入,  去找X牛
      接下来M行:Ai,Bi,Ti  表示A可以到B,权值是T
对于样例1
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
 最短路      最短路    总路程 
1->2  4  2->1  5         9
3->2  6  2->3  3         9
4->2  3  2->4  7          10
输出最短路的总路程的最大值是10 
去的时候我们可以看成是其他点到X点的最短路,就是Dijkstra。返回的时候,我们只需要把路径颠倒,也可以看成其他点到X点的最短路,只不过反过来了,其实就是X点到其他点的最短路,所以这就转化成了,两个单源最短路求值,调用两次Dijkstra就可以了。
具体请看代码:
#include <stdio.h>
#include <string.h>
#define inf 0x3f3f3f3f
int book[1005];
int dis[2][1005];
int e[2][1005][1005];
void init(int n) {
	for(int i = 1; i <= n; i++) {
		for(int j = 1; j <= n; j++) {
			if(i != j) {
				e[0][i][j] = inf;
				e[1][i][j] = inf;				
			} 
			else {
				e[0][i][j] = 0;
				e[1][i][j] = 0;					
			}
		}
	}
}

void Dijkstra(int x, int t, int n) {
	int mn, p;
	dis[t][x] = 0;//自身到自身为0 
	for(int i = 1; i <= n; i++) {
		mn = inf;
		for(int j = 1; j <= n; j++) {
			if(!book[j] && mn > dis[t][j]) {
				p = j;
				mn = dis[t][j];
			}
		}
		book[p] = 1;
		for(int k = 1; k <= n; k++) {
			if(book[k]) continue;
			if(dis[t][k] > (dis[t][p] + e[t][p][k])) {
				dis[t][k] = dis[t][p] + e[t][p][k];
			}
		}
	}
}
int main() {
	int mx = 0;
	int N, M, X;
	int Ai, Bi, Ti;
	scanf("%d %d %d",&N, &M, &X);
	init(N);
	for(int i = 0; i < M; i++) {
		scanf("%d %d %d",&Ai, &Bi, &Ti);
		e[0][Ai][Bi] = Ti;//去程 
		e[1][Bi][Ai] = Ti;//返程 
	}
	memset(dis, inf, sizeof(dis));
	memset(book, 0, sizeof(book));
	Dijkstra(X, 0, N);
	memset(book, 0, sizeof(book));
	Dijkstra(X, 1, N);
	for(int i = 1; i <= N; i++) {
		if(i != X) { 
			if(mx < (dis[0][i] + dis[1][i]))
			mx = dis[0][i] + dis[1][i];
		}
	}
	printf("%d\n",mx);
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值