POJ 3169 Layout

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate). 

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated. 

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD. 

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3
Sample Output
27
Hint
Explanation of the sample: 

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart. 

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

这是一道差分约束题,和POJ3159差不多,用SPFA两种实现方法都很容易过,需要判断是否为环,为环就输出-1,dis[n]=inf就输出-2,否则就输出dis[n]。
接下来写的两种方法,分别用栈和队列实现SPFA

#include <queue>
#include <stack>
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f3f
const int maxn = 1005;
int s[maxn];
int dis[maxn];
int book[maxn];
int head[maxn];
struct node{
	int e, w;
	int next;
	void Node(int x, int y, int z) {
		e = x; w = y; next = z;
	}
}e[2*maxn*maxn];
void SPFA_sta(int n) {//94ms
	memset(s, 0, sizeof(s));
	dis[1] = 0;
	book[1] = 1;
	s[1] = 1;
	int pre, nex;
	stack<int> sta;
	sta.push(1);
	while(!sta.empty()) {
		pre = sta.top();
		sta.pop();
		book[pre] = 0;
		for(int i = head[pre]; i != -1; i = e[i].next) {
			nex = e[i].e;
			if(dis[nex] > dis[pre] + e[i].w) {
				dis[nex] = dis[pre]+e[i].w;
				if(!book[nex]) {
					s[nex]++;
					if(s[nex] > n) {
						puts("-1");
						return ;
					}
					book[nex] = 1;
					sta.push(nex);
				}
			}
		}
	}
	if(dis[n] == inf) puts("-2");
	else printf("%d\n", dis[n]);
}
void SPFA_que(int n) {//32ms
memset(s, 0, sizeof(s));
	dis[1] = 0;
	book[1] = 1;
	s[1] = 1;
	int pre, nex;
	queue<int> q;
	q.push(1);
	while(!q.empty()) {
		pre = q.front();
		q.pop();
		book[pre] = 0;
		for(int i = head[pre]; i != -1; i = e[i].next) {
			nex = e[i].e;
			if(dis[nex] > dis[pre] + e[i].w) {
				dis[nex] = dis[pre] + e[i].w;
				if(!book[nex]) {
					s[nex]++;
					if(s[nex] > n) {
						puts("-1");
						return ;
					}
					book[nex] = 1;
					q.push(nex);
				}
			}
		}
	}
	if(dis[n] == inf) puts("-2");
	else printf("%d\n", dis[n]);
}
int main() {
	int n, m1, m2;
	int t1, t2, t3;
	scanf("%d %d %d", &n, &m1, &m2);
	for(int i = 1; i <= n; i++) {
		head[i] = -1;
	}
	int t = 0;
	for(int i = 0; i < m1; i++) {
		scanf("%d %d %d", &t1, &t2, &t3);
		e[t].Node(t2, t3, head[t1]);
		head[t1] = t;
		t++;
	}
	for(int i = 0; i < m2; i++) {
		scanf("%d %d %d", &t1, &t2, &t3);
		e[t].Node(t1, -t3, head[t2]);
		head[t2] = t;
		t++;
	}
	for(int i = 1; i <= n; i++) {
		dis[i] = inf;
		book[i] = 0;
	}
	SPFA_que(n);
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值