Mike and palindrome

Problem:Mike and palindrome

Description:
Mike has a string s consisting of only lowercase English letters. He wants to change exactly one character from the string so that the resulting one is a palindrome.
A palindrome is a string that reads the same backward as forward, for example strings “z”, “aaa”, “aba”, “abccba” are palindromes, but strings “codeforces”, “reality”, “ab” are not.

Input:
The first and single line contains string s (1 ≤ |s| ≤ 15).

Output:
Print “YES” (without quotes) if Mike can change exactly one character so that the resulting string is palindrome or “NO” (without quotes) otherwise.

Sample Input 1:
abccaa

Sample Output 1:
YES

Sample Input 2:
abbcca

Sample Output 2:
NO

Sample Input 3:
abcda

Sample Output 3:
YES

Language:C

#include <stdio.h>
#include <string.h>

int main()
{
  char s[15];
  gets(s);
  int n=strlen(s);
  int count=0;
  int i;
  for(i=0;i<n/2;i++)
  {
    if(s[i]!=s[n-i-1]) count++;
    if(count>1) break;
  }

  if((count==0&&n%2==1)||count==1) printf("YES\n");
  else printf("NO\n");

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值