Memory and Trident

Problem:Memory and Trident

Description:
Memory is performing a walk on the two-dimensional plane, starting at the origin. He is given a string s with his directions for motion:

An ‘L’ indicates he should move one unit left.
An ‘R’ indicates he should move one unit right.
A ‘U’ indicates he should move one unit up.
A ‘D’ indicates he should move one unit down.

But now Memory wants to end at the origin. To do this, he has a special trident. This trident can replace any character in s with any of ‘L’, ‘R’, ‘U’, or ‘D’. However, because he doesn’t want to wear out the trident, he wants to make the minimum number of edits possible. Please tell Memory what is the minimum number of changes he needs to make to produce a string that, when walked, will end at the origin, or if there is no such string.

Input:
The first and only line contains the string s (1 ≤ |s| ≤ 100 000) — the instructions Memory is given.

Output:
If there is a string satisfying the conditions, output a single integer — the minimum number of edits required. In case it’s not possible to change the sequence in such a way that it will bring Memory to to the origin, output -1.

Sample Input 1:
RRU

Sample Output 1:
-1

Sample Input 2:
UDUR

Sample Output 2:
1

Sample Input 3:
RUUR

Sample Output 3:
2

Note:
In the first sample test, Memory is told to walk right, then right, then up. It is easy to see that it is impossible to edit these instructions to form a valid walk.
In the second sample test, Memory is told to walk up, then down, then up, then right. One possible solution is to change s to “LDUR”. This string uses 1 edit, which is the minimum possible. It also ends at the origin.

Language:C

#include <stdio.h>
#include <string.h>
#include <math.h>

int main()
{
  char s[100010];
  scanf("%s",s);
  int n=strlen(s);
  int i,ans;
  int L=0,R=0,U=0,D=0;

  for(i=0;i<n;i++)
  {

    if(s[i]=='L') L++;
    if(s[i]=='R') R++;
    if(s[i]=='U') U++;
    if(s[i]=='D') D++;

  }

  ans=(fabs(L-R)+fabs(U-D))/2;

  if(n%2) printf("-1");
  else  printf("%d",ans);

  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值