迷宫问题(bfs)

Problem:迷宫问题

Description:
定义一个二维数组:

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input:
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output:
左上角到右下角的最短路径,格式如样例所示。

Sample Input:

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output:

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Language:C++

#include<iostream>
#include<queue>

using namespace std;

struct node
{
  int x;
  int y;
}head,tail,res[5][5];


int maze[5][5];
bool vis[5][5];
int step[4][2]={{0,-1},{0,1},{1,0},{-1,0}};

void bfs()
{
  queue<node>q;
  head.x=4;
  head.y=4;

  q.push(head);
  while(!q.empty())
  {
    head=q.front();
    q.pop();

    if(head.x==0&&head.y==0)
    {
      cout<<"(0, 0)"<<endl;

      int i=0,j=0;
      while(i!=4||j!=4)
      {
        int next_i=res[i][j].x;
        int next_j=res[i][j].y;
        cout<<'('<<next_i<<','<<' '<<next_j<<')'<<endl;
        i=next_i;
        j=next_j;
      }
      return;
    }

    for(int i=0;i<4;i++)
    {
      int tx=head.x+step[i][0];
      int ty=head.y+step[i][1];

      if(tx>=0&&tx<5&&ty>=0&&ty<5&&!vis[tx][ty]&&maze[tx][ty]==0)
      {
        tail.x=tx;
        tail.y=ty;
        res[tx][ty].x=head.x;
        res[tx][ty].y=head.y;
        vis[tx][ty]=1;
        q.push(tail);
      }
    }
  }
}

int main()
{
  for(int i=0;i<5;i++)
  {
    for(int j=0;j<5;j++)  cin>>maze[i][j];
  }
  bfs();
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值